Getting error on Build - SHA1withRSA security

Hi Gurus,
I have been using same passowrd and same tool, created 2 watchfaces in last 1 month. No change in hardware or software but I have started getting this warning/ error (actually its an error as it wont generate aab) when I try build the WF.
Attached is the error I get.
Worst is its not consistent. I tried sometimes restart it worked but next time restart dint work.

So im confused.

I have WFS version 1.3.13 and I could sync the wf with my G4 with no issues. Even for this latest wf where Im getting this error, it syncs.

Any pointer appreciated.

Screenshot 2023-03-05 183908



The most common reason for not generating an .aab is because of the
The Package name must have at least two segments (one or more dots).
Each segment must start with a letter.
All characters must be alphanumeric or an underscore [a-zA-Z0-9_].
Do not use any non standard characters

The other reason for getting a confusing certificate error is the keystore password
A valid password can contain 6 to 30 characters, begin with an alphabetic character, and use only alphanumeric characters and special characters like Underscore (_), Dollar ($), Pound (#). The password must contain at least one number.

If this is your watch for your own use. I’d suggest you create a new keystore file and alias making sure you include the 2 letter country code. (It apparently is used in the code algorithm)

If that doesn’t work then respond here and I’ll contact you to get a log of the build.

Samsung Developer Relations

Thanks @r.liechty_SDP
Sorry for replying late, been busy lately.

I have all mentioned things but somehow the prob comes intermittently.
password is also 8 char and has all alphanumeric, caps and special char (such as # $)
I have not build anything after that as Im busy with my primary work.

When I encounter i ll update you here then we can go for Log.


There is a log in
For Windows in C:\Users{User}\AppData\Roaming\watchfacestudio\dump\main.log
For macOS in /Users/User Name/Library/Application Support/watchfacestudio/dump/main

Next time you encounter that save that log. delete or rename the log so you create a new one before launching WFS then try to build your project again. The log can get pretty long.


Ok cool. Thanks for the pointer on log. I’ll try to do the build over the weekend.