Gyro effects issues

What I initially tried to do is make an object rotate only on the X axis and only between 0° and 45°. Unfortunately this is not possible. I can either choose for the object to rotate on both X and Y axis between 0° and 45°, or I can choose for it to rotate only on X axis, but between 0° and 45° AND between -45° and 0°. I found all sorts of solutions, but either they only worked in GWS and NOT on the watch, or they didn’t work at all. I tried submitting these as suggestions through the Galaxy Store Seller Portal, but they told me to come here. Does anyone have an idea if there’s a workaround or if there’s a way to make this issues known to the team that created GWS?

I also added 3 images with the explanations, I hope they’re understandable.

Thank you for your time!

Open a Developer Support Request and attach all the images you have here. This can either be an issue with the Watch software or GWS, I think they can sort it out.
I didn’t notice anything you had that was different than the tutorial so it sounds like a bug somewhere. But then Gyroscopic complications are one aspect I never really got a good grasp of. :slight_smile:

Samsung Developer Relations.

Thank you, Ron. I have a few other suggestions, should I submit them there too? They’re all about GWS, things that could be easily implemented and that I strongly believe would be helpful to everyone.

There is a forum here Feature Request - VOTE and Galaxy Watch Studio is in that. Add your suggestions there and others can vote on them. I collect Those suggestions and send the suggestions to the product manager for evaluation. If there are a lot of votes I make that known.

I think your Gyro effects was a bug not a request as the preview and watch should act the same.

Samsung Developer Relations

If it’s a bug, it’s kinda weird, since it has been there for a long, long time. But I guess people simply thought that it’s as designed. Anyway, I submitted it in the Feature Request - Vote, but the topic hasn’t appeared… It has to be approved, first?

Thank you!

Both of them are appearing to me. Maybe you needed to refresh the page.