Can't connect Galaxy Watch Active to Galaxy Watch Studio! Help

Hey everyone.

So im trying now the whole day to get a connection between my PC an my watch to install a watchface. I tried every way, so just with WiFi and with my phone in between. Nothing works. I did every step, Debugging, etc. When I search for devices at “Run on Device”, my Watch won’t show up. I think the problem is, that I never got the RSA notification on my watch. I already rebooted my watch, but that hasn’t worked.
I hope someone can help me, I’m frustrated.

in the C:\Users\username\ folder is a hidden folder .tizen in that folder is sdbkey and sdbkey.pub hide them in someway, zip rename, move, etc. Restart your computer don’t just turn it off and on.
Hold down the power key on your watch for 15 seconds until it says rebooting

Launch GWD. get the IP address for your watch from the settings connection WiFi network setting
wait one full minute after restarting the watch
Set it to a factory watch face like Dashboard
try to run on device click the + sign enter your watch IP address
Keep your watch active and watch it like a hawk.
the RSA acknowledgement should show up.

You may need to create a new distributor license if it gives an error when side-loading to your watch.

If that doesn’t work you probably have a firewall issue and you need to use SDBoverBT to load on the watch.

Ron
Samsung Developer Program

Alright, I will try that.

Thank you so much!!! Finally it works.