I can not run A face on my watch Today

I got the UI5 update on my watch today . GW4 classic . I can not transferee ( Run ) a face to my watch . I am still using 1.3.13 , Have been without any problems . I have followed all Rons @r.liechty_SDP Steps . I have done many many transfers to my watch . I have tried everything . Even Building the Face . I am missing something but I can not put my finger on it .

Steps for Watch 4 are much different.

you have to get the IP and Port number from ADB
then you have to pair the device and use a different port number for that
and enter that into the run on device dialog.

Then You have to wait because the search appears to have timed out… but it didn’t it just takes longer
so if it says no devices found don’t believe it wait a half minute or more and it appears.

If you go to sounds you can set a sound for when ADB connects that is useful

I spent a good half hour trying to connect one time until I realized I just had to wait and not try try again.


1 Like

Thanks Ron . I have been sending stuff to my 4 for ages . Like a year now . I am not understanding these new instructions . I hope if I give it a go it will become clearer . I have tried including the Port number in the previous method but I ge t Invalid IP address .
I am not understanding " get the IP and Port number from ADB " ADB on my watch is just a switch . There is no data there .
Listen Ron I am so sorry I see this topic has come under Watch Face converter . I did not intend that . That was an accident . I thought i had jus posted it onder Watch Face studio . So sorry .

Hello! Today I also received an update for my GW4 and had to figure out what to get from where and where to enter it. For Android 13, the instructions differ from the previous one. Having figured it out, I made a small cheat sheet for myself and I think it will be useful to you.

Ensure that your workstation and device are connected to the same wireless network.


Tried this, NO JOY :frowning:

1 Like

Unstable at best…persistent is key.
Good luck

Sometimes its work, sometime it doesnt.

Things i did when it fails.

Turn off adb debuging , Disconnect wifi on watch…reconnect then
Turn on wireless debuging again.

Close wfs. Open wfs, open project then try again.

Sometimes need to restart os

Might be because wifi Disconnects to safe bat

I found this on google. This info might help


Thank you @skymax . Great Cheat Sheet . Nice Work . So that is a graphic Illustration of what Ron was trying to tell me. My Word that is Different from how it worked the,Day before .
Sadly I have no Idea how to get the Page on my phone that you showd in the Illistration .
This thing that bothers me is every Time I reconnect I see a different port number . So the port number and Paring number will have to be done over and over .
This has stopped being a Fun Game . I can understand the effort is worthwhile if you are making money but as an Amateur with Asperations it is a bit Painful .
As @Knightwing has pointed out the WiFi Disconnect is remarkably Agressive . As a Senior stuff takes a bit longer . I feel like I have suddenly turned into a No Hoper .
I have tried to get the IP address to Forget itself and reconnect . I keep getting the Same IP address after that . I am sure it should have changed .
Thank for the response .

What network u using personal? If personal u could reserve ip to your watch via router. Which i did. For ports unsure how to maintain

1 Like

Thanks . I am sure my WiFi connection is Personal . I am at Home . The IP Address stays the same . It is the Port address that changes . I dare say that is not reservable . I have ever had to use the Port Address before . I am starting to understand that I have to go to the Console on my Laptop to get to the Port Paring number settings . I hate to think I have to do this every time I sync A Face . I do it every 15 minutes when I am developing something . It looks so different on my Watch .

I think it for security that the port changes…
Alternative you could try adb connect ip:port
To connect first. Onces connected from cmd. U can do scan for device…

1 Like

Yeah . Thanks I am going to have a look today . I never had to do that before .


Did you find any solution. As shown above i cannot find a place to enter port no in WFS 1.3.13. There seems to be no option in 1.13.13 to enter port number

I updated my ADB Platform tools to latest.

This was shared on another same same but different topic

By the way i just googled the changing port thing is a android 11/12 and wear os thing.

1 Like

I think my problem is Getting the correct IP address from the Modem. I will post some shots later .

Ok…but what i did on my router is bind mac address to ip. The ip wont change after that

1 Like

Never Mind .Reading another thread i was able to connect via adb command shell thanks to isaac’s post.

0.I updated my ADB Platform tools to latest.
1.I successfully paired 1st via paiing code command
2.Then i used the adb connect command
3. The watch was not showing in WFS 1.3.13 so i restarted the watch and now watch appeared


Thanks @Knightwing . I have not been into the Router settings for Years . Seems like I have to Walk that Walk .
It looks to me , having read other posts , that the watch now connects to the PC / Laptop not the Modem . Hell I am getting Confused .

I followed these steps and my Watch 4 Classic connects fine. But then the wheel on the Run on Device button spins foever and nothing happens. So my watch face does not upload und install on the watch. What can I do?

1 Like

Try again it happens time to time…untill they have something more stable we have to rely on retries…

Haha…of course it connects to your laptop via the modem/router. And the router assign ip to each of your devices