Incorrect Keystore password issue

Hi, unfortunately, I have to return to the keystore password topics mentioned several times here.
I read all the posts on this topics and tried all possible options before writing here : like re-install WFS / use correct location for files/ use applicable password / e.t.c.
Previously keystore password worked for me on the same mashine, at the moment I can’t build an aab file using the “create new key” option. It gives warning : “Keystore password was incorrect”
Using “Key explorer” program, I was able to open “keystore.jks”

file, but I’m not sure what to do to fix the error. Maybe there is someone who can look into this error:

KS error

Thanks :thinking:

Are you using a valid password?

A valid password can contain 6 to 30 characters, begin with an alphabetic character, and use only alphanumeric characters and special characters like Underscore (_), Dollar ($), Pound (#). The password must contain at least one number.

Is this the issue? @Peter reported the same issue in a different thread.

Samsung Developer Relations

Hi, Ron.
Thanks for your response. Yes, I use valid password. Even more than that, I have used this password before and everything was fine.
Now I’m trying to create a new keystore password by using a different valid password, and have get the same error.
Again, I read all the information available and tried all the options, but without success. That’s why I sent all the data available to me.
Is there any way to reset the user account? Just if no one knows what the problem is, then this is what remains to be done …


Did you happen to use the TPK conversion tool at some time. I remember there was a bug with the keystore.jks file with that.

Try moving the current keystore.jks file to a different location and restarting your computer and see if you can generate a new one that way.

If that doesn’t work then I’m stumped and you will need to open a support request.

Samsung Developer Relations

Hi, thanks, Ron. No changes. I will open a support request.

For me this worked. Thanks Ron.

Hi, finally after Watch Face Studio uninstall it was required to delete a folder “WatchFaceStudio” in the user directory.
Done manually. That helped.
Otherwise it uses the old keystore file.
After WFS reinstall it able to create a new keystore file.

1 Like