Launch Error

Just got a launch error code after building and running on device. has anyone got this, I’ve never had any other faces do this.

The pop up just says launch complete with a yellow triangle ! in it and when it runs on the watch it does not show the face just a digital clock that flashes. Have to go into the phone to delete the face to have a different face work to stop the flashing digital clock.

Any suggestions?

I’m seeing a slight delay in the seconds hand movement using normal or sweep happens on both. Is anyone else having this issue? This is something new.
this issue is causing a major problem with the face running on the watch. It will build just fine but once it runs and installs on the watch it does not work properly. The watch face goes black with a white digital time face flashing slow and it’s hard to get rid of the face on the watch but you can delete it from the watch using the phone.

I don’t find any issue in my side. Can you give images or video in which the issue can be understandable? Please share the issue reproduction steps also.

HI Ross,

Did you copy anything from the Normal watch face to the Always-On watch face That will raise havoc with the memory and give all sorts of weird results.
If you want the same thing on the AoD use the show and don’t show or a new component.
Do not make a copy of a component if you were a programmer you’d understand.

Samsung Developer Relations

hey Ron

I’m not using the same stuff on the AOD. Using the on and off of the layers, the only thing from the watch face that’s showing is the index. The delay in the seconds hand is that it moves a few seconds then it pauses for like a second and then moves again it doesn’t move like normal on sweep or normal. I’m trying to get video to show what is happening with it.

How do you clear the memory or cache in the program? I just deleted the watch face and started over with just adding background, index, watch hands and still getting the delay in the seconds hand.

The other thing is when I open other projects I did before this issue now they are doing the same thing with the seconds hand with delay.

Hi Ross,

Just to be clear you are not using a second hand or seconds in a digital clock on AoD mode that will never work, AoD does not support seconds.

If you hold down both buttons for about 15 seconds on your watch it should start rebooting that will clear any cache on your watch but not remove or change any programs. You can do a factory reset if you don’t have any special apps.

Other than restarting your computer to clear a cache, delete the build tpk/aab files don’t just rebuild them.

I don’t know about the Wear OS watch faces but with Tizen fonts and some images will cause memory issues but usually they won’t sideload at all

Hope that helps.


Hey Ron,

Nope not using the seconds hand on the AOD.

Where can I find the folder with the files in it tpk/aab? I’ve looked around and can’t find them.

I am using a new font but it wasn’t causing any issues before and it is the right type of font for the program. I’ve also restarted my computer which is weird because this is a new issue all of a sudden never had this issue before with any builds.

I can even make the most simple watch face run the preview and get them same issue with the seconds hand.


You set that in your project menu the first text box is Location. By default it is just the workspace where your .wfs files are at but many people like to have them in a special build folder or a different folder for each project.

You probably should uninstall WFS reboot (don’t just turn off and and that doesn’t clear the cache) and reinstall it in case something is corrupted.


ahh got ya will do and let you know.

Ok I uninstalled the program and installed it again. Still get a get the leg when the seconds hand is set to sweep. But normal it seems to run fine. I’ll have to rebuild it and run it on her watch to see if will work ok.

Are you using latest version 1.1.9?

This problem just started. i had no issues till a few weeks ago.

The Second Hand Sweep has an Update Frequency could it be that you accidently changed that?

Is this a WFS second hand or an image you created? And if is one you use what type of file is it?


It’s the second hand issue and it is set on the 15hz like always but it moves in a sweep but hesitates for every second. I didn’t make it I used one of the hands it provides. But does it on ALL watch faces even a very simple one with just the index and watch hands. The files it comes with are png.


Best I can do for the video to show whats happening, video will post not show the video just play sound. So here’s a link to see the video of what I am talking about.

Hi Ross,

I used index_modern.png and watch_sec_simple.png could not duplicate it.

I wonder if this has anything to do with your not being able to build a watch face did that ever get resolved.

A lot of time creating a simple example shows what was wrong.

If you still cannot build add this to that bug report as they could be related. If not open a support request and submit a simple example that duplicates this. Ask that I be copied on the support request.

Samsung Developer Relations

Hi Ron,

Yep still can’t build anything but I think I know why now. For some reason the program or my laptop is adding and changing the Country code from US to Florida on it’s own.

I deleted the main log file and did it a couple of times and each time it was changed to Florida. I even left it blank it was changed to Florida for some reason. Here’s the current file. I think it’s my computer but not sure, is there a fix for this? Because the program works perfect on my girls laptop just fine. And both are running the newest version of WFS.

[1.1.13][4/2/20229:51:44 AM][Socket.(KeyStore.js:127)] stderr: Generating 2,048 bit RSA key pair and self-signed certificate (SHA256withRSA) with a validity of 9,125 days
for: CN=Ross Perry, OU=mine, O=mine, L=Port Richey, ST=Florida, C=Florida
[1.1.13][4/2/20229:51:44 AM][Socket.(KeyStore.js:127)] stderr:

[1.1.13][4/2/20229:51:44 AM][Socket.(KeyStore.js:127)] stderr: [Storing C:\Users\rossp\WatchFaceStudio\keystore\keystore.jks]

HI Ross,

Try copying the keystore.jks file and replacing the one you are created and see if you can build then. The .jks is not computer specific. If it works make a back up :slight_smile:

Samsung Developer Relations

Hey Ron

I tried replacing it and I even opened it note pad and replaced state with right country code and still won’t build.

I tried replacing it and I even opened it note pad and replaced state with right country code and still won’t build.

You and one other user that I know of have the same problem.

I was told that there is an update planned this quarter that will show the exact error where the build fails but that is a few months out.

I don’t know what to do until then, it may not be the .jks file at all but something else. I’ll try to compare the two logs to see if there is something else.