macOS Server Response Code 401 when creating Certificate

I am getting “Server Response Code 401” when trying to create a SAMSUNG Certificate.

I see a lot of posts about creating certificates and have read the topics obviously but it seemed to be a windows related problem. I wonder if that is the case for the macOS Version of Tizen Studio as well since it is Safari being used instead of IE. Do I have to wait for the update as well or is my problem a different one?


I think this is because they are working on it and have disabled it for everyone.

Try it again next week and see if it works for you then. If not let me know.

Ron
Samsung Developer Relations

1 Like

Thank you for the support! I do wonder If I can use my old certificate. Unfortunately I was trying to generated a new certificate and deleted the old ones in the heat of passion since I don’t have a live app yet.

I still have the files but cannot reimport the xml. Looks like I will have to wait. Have a good day!

If you can un-delete it you should be able to do that.

Ron
Samsung Developer Relations

Just wanted to say, I have the same problem right now, 20:59 CET at 2023-09-07.

At least I can go to bed now :smiley:

In case this is interessting: First day with Tizen – pretty nasty to run into a serious flaw in the support infrastructure, that I have wasted about 4 hours on. I mean, getting a certificate is about the second stage in all guides for Tizen developements for Smart TV…

The issue is still happening this week


Fixed by updating Tizen Studio

2 Likes

Dear Support,
Our ad tech team is still experiencing this issue. We hope that this matter is a high priority and can be resolved soon as we must start debugging our samsung builds ASAP but can not continue without creating our certifications. Please get back to us with an update soon.

It should not be doing it did they apply the Samsung Certificate Extension update. I think you will need to reboot your system after applying it.

They aren’t using an older version of macOS are they? Apple has been pretty aggressive on forcing newer versions for security too.

If it still is getting the error please open a Developer Support Request

Ron
Samsung Developer Relations

I had the same problem and In my case I had to uninstall and install the whole tizen studio, which was annoying but nothing else worked for me

I’m currently experiencing this issue along with some other people at the same time.

[webide-common-tizentv]SamsungCertManager.init():init start…
[@tizentv/tools]tools.getSamsungCertPath: start…
[webide-common-tizentv]SamsungCertManager.createAuthorCert(): start…
[webide-common-tizentv]SamsungCertManager.generateAuthorCSR(): start…
[webide-common-tizentv]SamsungCertManager.fetchAuthorCRT(): start…
[webide-common-tizentv]SamsungCertManager.fetchAuthorCRT(): status code: 401
[webide-common-tizentv]SamsungCertManager.fetchAuthorCRT(): status msg: Unauthorized

Did you check for updates in the Package manager? There should be one for the Samsung Certificate Extension. Apply that and it I believe it works .

I don’t have a Mac to test it on but it works on Windows now.

Ron
Samsung Developer Relations

1 Like

the same to me. it dose not work on my MacBook. but it works sometimes on my teams win. can you help? @r.liechty_SDR

@don.xd.tan

Did you restart your computer (not just shut down as that doesn’t clear all caches) after you did the Samsung Certificate extension update. If not try it. I doubt it works but it is the easiest thing to try.

This is what I think is wrong…
Some Mac users especially those running the latest macOS say that they needed to uninstall Tizen Studio restart and then reinstall it to get rid of this error and generate certificates again.

This also happens once or twice a year when Samsung does some security updates on the server it changes the server information, but that happens to all Tizen versions not just Mac users.

Ron
Samsung Developer Relations

I had the same issue and fixed it by updating the Certificate Manager. Launch the Package Manager and check for updates; the Certificate Manager shows up in the Tizen SDK tooks > Baseline SDK (near bottom). I did have to change the Package Manager’s Package Repository (in configuration) to http://download.tizen.org/sdk/tizenstudio because the default one doesn’t work anymore. I’m running this on a very new Mac and a very old one, so it’s not the OS.

There should have been an update on this topic.

@jmouka

You are correct there was an update for the Samsung Certificate Extension that needed to be installed.

By the way for the new Sonoma release for Device Manger

MacOS Sonoma
Due to issues in the recent version of macOS Sonoma it will not be supported in the Tizen Studio until a planned release in spring of 2024.

There is a work around for those who are facing issue in launching Device Manager in macOS Sonoma, they can use following CLI commands for similar functionality.

  1. permit for install -

$ /tools/sdb devices
List of devices attached
emulator-26111 device t-1019-1

$ /tools/ide/bin/tizen install-permit -s emulator-26111
Install Permitted

  1. Install the app -

$ /tools/ide/bin/tizen install -s serial -n pkgname – <path to base dir of tpk/wgt>
e.g - $ /tools/ide/bin/tizen install -n org.tizen.basic-1.0.0-i386.tpk -s emulator-26101 – ~/workspace/basic/Debug

Ron
Samsung Developer Relations