Can't connect watch to WFS through bluetooth

Hi!
I’m trying to Connect my Galaxy Watch 4 to WFS though bluetooth, but I can’t figure out the last step: “Enable Bluetooth debugging on the phone”.
All guides I’ve found are outdated or incorrect, so every step has been a bit complicated. But now I just can’ find how to turn on the Bluetooth debugging on my phone.
Enabling BT debugging is supposed to be in the “Wear companion app”, is that “Galaxy wearable” or is it a specific app? Because I can’t find any BT debugging setting in the app, or in my phone’s settings.

I have enabled Developer options and enabled USB debugging on my Samsung Galaxy 10.
I’ve done all the setup on the watch.

My computer doesn’t have WiFi capabilities so that’s not an option.

These are the guides inside of WFS I’m trying to followed (combined with a ton of googling):
image

I have now transferred my project to my laptop to try the WiFi approach. Everything seems to go well until I enter the watch IP address into WFS and it just doesn’t find anything.
I’ve turned off BT and made sure it’s on the same WiFi as the computer. I read from some GWS that WiFi should be set to “Always” and not “Automatic” but I can’t find any such options on my watch.

Does anyone know hoe I might fix this?

Hi Saraliew,

I couldn’t get the bluetooth method to work, and to be honest it seems a bit complex and convoluted, so I have used the wifi method which is actually much simpler. Here’s what I did. (Note there is another thread with a similar discussion - “Galaxy Watch 4 not showing connected devices”).

  1. I downloaded the Android developer platform-tools onto my PC (SDK Platform Tools release notes  |  Android Developers) and installed them. This gives you access to the “adb” tool. Detailed instructions on doing this are in the other thread mentioned above.

  2. I followed the instructions here: Debug a Wear OS app  |  Android Developers to enable wifi debugging, down to the point that adb has connected to the watch.

  3. The watch then showed up as a target device in WFS when I selected “run on device”

A couple of additional detailed points…

  • On my watch when I enabled ADB debugging and then Wifi-debugging, a little message appeared under wifi debugging saying ‘unavailable’. I just ignored this and carried on. it all worked in the end.

  • When I issued the adb connect command from the laptop, the watch vibrated and asked me to confirm that debugging should be enabled, which I confirmed.

Best Rgds,

Rob

2 Likes

Thank you Rob, didn’t know I needed those tools!

Accidentally didn’t allow debugging when the watch asked the first time, so had to manually write a disconnect command and then connect it again, to make it ask again. In case anyone else gets a similar problem.

To simplify and avoid version conflicts, there is an adb included with WatchFaceStudio in the tools\window subdirectory.

After you enable wifi debugging in your watch, grab its ip address, open a cmd prompt in the X:…\WatchFaceStudio\tools\window directory and enter:

adb connect xxx.xxx.xxx.xxx:5555

After a few secs, your watch will ask you to allow the connection and you are good to go.

1 Like

Hello! My wifi debug watch does not connect to the studio. The IP address is not displayed on the watch.