My Project is gone!

WTF. One of my project is gone.
I checked my workspace. The wfs file is there, but 0 kb.

There is nothing happens where i could say ok this is maybe the problem. How the f… is this even possible?

Is there any chance to get the file back? Are there any log files to check what is happened?

Btw. i did finalized this project yesterday and did upload it to to the play store for review.
So when i have to update something … its not possible anymore?


Yep… it happened to me three times. I prepared for that twice and made a copy of .wfs every time I saved project in WFS.

I don’t know exactly how this error will occur, I won’t find out until I go to build the dial and I get a message that a font is missing or that the build failed. Right away I go to the workspace and the project suddenly has only a few kilobytes - all .xml & some other files are missing from the inside.

So for now is better to make .wfs project file copy every few minutes just in case.

I thought this might be because I used the “Import GWD” option when creating the project but I can’t verify it. Maybe you did that to ?


Yes I have seen this issue as well now I have script which will backup to the cloud I run every time I save project.

I’m not using imports from GWD making all faces from scratch and using assets found to many issues when using this method.

I did build up from scratch. So this can happen to EVERYONE. This is wild!
I really hope they fix this fast as possible.

So when i build up it again. Is it possible to use this new Project to update my old one (when using same names and so on)?

So far I have always used only a copy of the previous project. Google Play upload was fine. It is possible that you really just need to build with the same package ID and the same key alias. Haven’t tried that yet.

Edit: Maybe this is Windows version related error, maybe some program cache error. I dont know but it’s nothing nice to experience it as you wrote.

Finally i have to try it. Thx.

I opened a bug report on this.

I could semi reproduce this, the .wfs project disappeared from the preview window after a failed build but was still in the workspace and could be opened. But this was a very small project.

Samsung Developer Relations

1 Like