Missing assets in watchface?

Hello Everyone,
I hope you all are doing great,

I have made many watchfaces on Playstore…
Recently, i updated to 1.5.7 Beta…

So far, made few watchfaces, and I’m updating my old watchfaces with the new version…

but there is one specific watchface with an issue, and it’s a new one…

According to Google Play, there are missing assets, i went to the project as a zip file, inspected the honey file for the missing asset name they provided, the preview for some reason is referring to my C Drive temp folder instead of project itself…

The background is a gif (and it can change to 4 other gifs), as a workaround i updated the honey file and removed the preview, now on playstore the watchface has no preview when changing between backgrounds…

I said I’ll just redo the whole thing, maybe the project got messed up somehow, but still the same issue, even though i updated honey file and moved the preview from my C drive into the projectand changed the preview path to read it from the project drawable-nodpi…

Is this a bug…?
What can i do about this…?

Thanks in advance and i hope you all had a great happy new year celebration…

I believe that the WFS team is aware of some issues with cached assets. I think it is when you copy something in WFS and paste it back in. Or you delete it from AOD and paste it into active mode (or vice versa) That is my first thought.

I’ve also heard of issues with people using images in the cloud instead of on their local computer. If I recall correctly restarting the entire project was the only solution making a clone of the project did not work.

Samsung Developer Relations

Every time I want to update something, i have to delete all of the gifs, save and close the project, then open it again, add the gifs again, adjust the dimensions and everything, then apply my change and build it; the size would be 15 MB, and if close it and open it again, the size becomes 7~9MB…

I know this because i viewed the assets in the aab file when i open the project and build, assets are missing, when i do the steps i explained and build, the aab file has the assets…

I do use files from my Google Drive client desktop. I have always been doing that because I always need to have access to my files in case I need to update the Play Store app. Oddly, only gifs are having issues, other assets are fine…

Any ETAs for the next release of Watch Face Studio with fixes…?
Thanks a lot

This may be an issue when saving to the Google Cloud I have heard of this when saving to Adobe cloud. Google obfuscates the path to the cloud so when you do an update to the project the resources are not in the expected path. If you are using other resources from the same spot and they are working correctly then it is a bug.

I’d be curious if this happens when you store the GIFs locally.

I expect a new release this spring. If you reported this as a Developer Support Request it may be in the system for a fix.


but shouldn’t the files be part of the project?
why is it looking for a path…?

thankfully I put everything in the same folder of the project, I had a feeling the project will be ruined and assets will be gone or corrupted, almost as I can not trust the project…

you’d probably say “this is to ensure you don’t run out of storage” or something like that but I don’t think I would because it’s few megabytes…

I just tried opening a different project and the font is gone, but looking inside the project as a zip file, the font is there but unable to load it?

I took the font out (it had a long name with numbers, probably watch face studio made it), shortened the name, added it, the font worked…

Not sure if this is the same issue related to cloud or new watch face studio (or maybe just beta) can’t open old projects without messing them up…

but shouldn’t the files be part of the project?

They should be in the .aab /apk file but the path is in the .wfs file look at the size of a .wfs file compared to the .apk or .aab file size.

I don’t think it was like this before but in the latest version of WFS the fonts are tied to your project not added to list of installed fonts.

It used to be you had to install the fonts in Windows and add the font to a path that WFS would discover. That is C:\Users\Ron\WatchFaceStudio\Workspace\Fonts
is where I put mine.
I’m not sure if you have to install them in Windows and the subfolder is just easier to add the fonts.

Having said all that I agree it is a good idea to back up the projects especially if you have the watch faces published.

Samsung Developer Relations

very odd…
I think the project should have project paths as in
and so on…

and never use anything from Windows resources or paths to avoid issues, this beta update may have nice things but in terms of using resources, I feel a huge setback was put in it…

Perhaps notify the devs about this because now all of my projects I have to remove the missing resources and add them again and the worst thing, even after doing that, the project does not save things correctly, files are absent inside the aab if I compile from a saved project (depending on what the project has)

Appreciate your time…

I think I am not understanding what you want.

When I add a font to my project the actual font.ttf is stored in the .wfs project resource\font folder

If I want to use them for other projects I created a username\watchfacestudio\Workspace\Fonts folder and put the font files in it.

When you open a WFS project it create a temporary folder that you work in and when you close it it writes the data to the .wfs file. Your resource should be stored there.

To me the issue isn’t in Watch Face Studio or the project format it is the cloud obfuscates the file name/path (that is where the numbers came from. Watch Face Studio does not change the .tff file name.

For the most part the 1.5.7 beta is only for the plugin if you don’t need the new features there isn’t any reason to update your watch faces.

  1. Common
  • Support Plugin feature.
  1. Project Management
  • Add Plugins Tab in Preference dialog.
  1. Edit & Properties
  • Add Rounded Rectangle.
  • Rename Animation component to Image Sequence.
  • Rename Multimedia component to Animated GIF/Webp.
  • Improve Tag Expression Searching.
  • Add guide text for Version Code in Publish dialog.
  • Add monospace fonts.
  • Remove Step Goal slider in Run Tab.
  1. ETC
  • Fixed minor bugs and GUI improvements.


That’s the thing, in older watch face studio, everything loads from my old wfs file…

In the beta, all fonts are broken, the fonts exist inside the wfs project, honey file shows the correct path and font, but it’s not rendering…

I just copy the font, rename it by remove any extra random digits and characters, add it again to the project and select it, all is well, i didn’t use any cloud path but i don’t want to do this with all of the projects because I’ll likely forget to change something and push the update to playstore incorrectly…

Unless you’re telling me, moving the project wfs to cloud and then downloading it can affect it (which makes no sense)

It is understandable if using resources from cloud has issues even though older versions worked fine, but i really whatever resource i select should be copied inside the project and the honey file uses the path of project in terms of assets and resources, just like android studio, everything is inside res folder and reference would “./res/drawable” and so on, without even renaming the asset…

I’ll try to share an example tomorrow, not the project but a screenshot of what i mean for the fonts…

Thank you for your patience…


Please share more, I just don’t see any issue in my simple test projects and this has only came up before with Adobe cloud resources and if the project crashes for some reason. I probably am just having a problem visualizing the issue.

Samsung Developer Relations

Sorry for the delay…
Here is a project:
When I open it
Fonts are broken…

When I go select a font, I see it as:

As for the project, and this is where I add my fonts and use them:

Checking the project for fonts shows:
And these are valid font files, as I said, I can extract them, rename them (I have to shorten the name before using them, otherwise, it won’t work)…

And honeyface file shows:

And this happens with all of my projects…
Could this be a bug…?

I think it probably is a caching problem from your description. Please submit a bug report and include one of the original .ttf fonts without being renamed. (in case renaming has something to do with the issue) but mention that you do rename the font.

How to add fonts is pretty poorly documented for WFS, and I’ve never used the Projects → Settings to add a font. I thought it was just a way to set the default font but it does add them.

I’ve always done it this way, a carry over from GWS days.

  • Drag and drop the .ttf file into the WFS workspace searchable directory such as /Fonts
  • In the Properties > Appearance > Font drop-down list, click Add font. From the file manager, select the font to add.

For GWS there is this note
On macOS, the font had to be installed before it can be added to GWS. That probably is the same for WFS.
To install the font, double-click the font in the Finder and click Install Font.

I’ve always installed the font with Windows but it probably isn’t necessary.

I’ve read that if a .ttf was designed on macOS and used on Windows they are not fully compatible and that may be an issue.

Bottom line is this probably a bug as you thought.

Samsung Developer Relations

As far as I know WFS saved the file name of font and image based on file name+encrypted date. So when we made a watch face in 24th January then we did not save the project, when you open the project in 25th January and save it, all the font and image will disappear because the project can not find that files. The solution is reimport all the assets with different file name. CMIIW.


WFS creates an encrypted temp file and does not write to the project until the project is saved then the encrypted folder is removed. If you close the project without saving it won’t have the assets.

I don’t understand why you need to rename them.

Samsung Developer Relations

These are old projects that have been published to playstore…

Opening them with the beta (as seen from screenshots) shows broken fonts…

I didn’t rename anything myself for yhe project, but if i want to use the fonts from the project since they already exist in the project and for some reason not rendering, using the font with (as @ZNW said) encrypted date, it doesn’t work, i have to rename the font, remove the encrypted date, the font works, save the project, close it, open it, broken fonts…

Could it be the issue with very old projects that beta cannot upgrade/render them…?

Yes it could be, Watch Face Format started with 1.4.13. You can’t open newer projects with the older version of WFS.

Try opening them with the 1.3.13 version then a newer version. Peter uploaded a Windows version 1.3.13 In this thread

If you need Mac there is a copy of that too, just search in this category for 1.3.13

Let us know if that helped.

Samsung Developer Relations