New issues connecting Galaxy Watch to GWD

To modify the app in the store you need the original Author’s certificate. This is a safeguard so that no one other than the original author can modify an app.

You will need to update it as a new app. You can suspend the old watch face and if users need to reload it they can so that. If they write that they want the newer version generate a coupon for them.

For others that read this, You do not need to create a new distributor.p12 you only need to create a distributor certificate for the watch.

Samsung Developer Program

I’ve been trying to upload a new watch face that I created, not update the old one. I created one from scratch, and it still won’t let me add it to my watch (keep getting the cert error window) nor will it let me upload the binary (tells me that this cert is already in use). I’ve even tried new passwords and new author cert and new dist cert. for some reason GWD thinks i am trying to upload a very old watch face that i really just want to delete.

Just to be sure you want to side-load it to your watch not upload it to the store correct?

First off have you rebooted (not turned off and back on) your computer after generating the new Developer Certificate. Have you deleted the .tpk files and regenerated them before rebooting? Just need to be sure there are no caching errors. It really sounds like a caching problem.

In the USER\GalaxyWatchDesigner\Keystore folder look for your author.p12 and distributor.p12 and make sure those are indeed the correct dates.

Is the OPR for your always on display below 12% I know the requirements are 15% but sometimes they won’t install when it is over 12%

On your watch press and hold the home key until it says rebooting takes about 15 seconds.
Restart Computer, Phone as well

Rebuild your watch face again

When you go to push it to the watch you will need to OK the RSA encryption key again as rebooting forgets your acknowledgement.

If it still doesn’t load can you create a support request and submit the .gwd file and mark it for Ron and I’ll see if it loads on my watch.

Samsung Developer Program

Hello Joe,

I think I found the problem when researching something else.
Watch Faces built with Gear Watch Designer (not Galaxy Watch Designer) installed on a device that has subsequently been updated to Tizen 3/4 can not be removed without a full factory reset of the watch. You can do that, it will remove any apps you may have installed and may require applying updates again.

You can only install new Watch Designs with a different name.

Samsung Developer Program


First, thank you for all the help. I appreciate it.

Everything I’ve done is truly brand new. you helped me get 1.8 working a few days ago, so that was a new install. Also, I just got my Galaxy watch on Thursday (4/16) so it started from a fresh build before i tried to upload. I would think that this should be easy since I have a new GWD and new watch that this should work. I’ve attached my GWD file for you to try. The old watch face that’s on the store is called Serenity Watch. I was playing with watch designs back then. This isn’t even a watch I want to keep on the store. I just uploaded the .gwd file to the support web site and included your name (Request # 22801 today with the Subject: Watch face upload issues - For Ron (r.liechty_SDP)).


Hello Ron,
i still can´t connect my watch. I have no ideas any more what i´m doing wrong. With Win7 i had no problems, was always able to connect my watch.
Can the author certificate be the problem? I generated it with Win7 and GWD 1.71. Now i´m running Win10 and GWD 1.81. Is it maybe a Win10 authorization problem?

What i did:
Rebooted devices
Enabled developer mode
Enabled Debugging
Connected phone via USB to computer
Connected watch to phone over SDoverBT

But i wonder that never the RSA key shows up…? GWD can still only find my phone, but nut the connected watch.

Maybe you have any other idea.

Thank you for your patience :slight_smile:

SDBoverBT requires you allow USB Debugging on your phone’s developer settings.

You need to approve the RSA encryption key. Hold down the home key until it says rebooting. restart it and your computer. wait at least a minute before trying to connect.

Next time you try to run on the watch, observe it very closely and keep it active. An RSA key acceptance will pop up ok it. If you don’t do it in time it will think it is a hack and not show again. You’ll need to reboot (not just restart) the watch again for the RSA key to appear again.

The RSA Encryption is necessary for Privacy laws in Europe, USA and many other countries.

Samsung Developer Program

Hello Ron,

thank you very much for your patience and your help. I really appreciate it!

USB Debugging is “on” on my phone.
Has the phone and watch to be connected to the pc via usb while rebooting?
What is the difference between “restart” and “reboot” the watch? For me it seems tha t i only have one option to turn off and on the watch by holding pressed the homebutton.
What about GWD? Should it be launched or not before connecting?

With Win7 i never had an RSA key…?

Thank you,
best regards

You need to hold down the home key for 15 seconds or so and it will reboot. Rebooting is a soft-reset no data is lost but caches are removed and maybe some settings may go back to default. I’ve done it a few times and don’t recall any setting that had to be changed.

This actually has nothing to do with the computer system but with regulatory laws.

In previous versions before GDPR there was a different wording and I believe you had to acknowledge it yes or no to continue. After GDPR and other countries privacy laws it only stays a short time and it takes no acknowledgement as a NO and does not repeat. This is so people can’t get close and send information or gather information from your mobile or watch device.

Samsung Developer Program

Hello Ron,
yes maybe in the past there showed something else short up. I´m pretty sure that i confirmed with “yes”.
If not, do i have a chance to retry?
In fact the watch doesn´t show up in GWD…

If a reboot of the watch doesn’t force the RSA key to show up when you first try to connect using SDBoverBT

Restart the phone and computer and connect to the PC again. Watch your phone when you start to connect to the device and there may be an RSA Key on the mobile first then the watch.

I don’t like to suggest this but…

If you are on windows (10 for example) go to your “Users”-folder of the logged in account and search for a “.tizen”-folder. There are 2 files in it called “sdbkey” and “”.
Delete those files or move them somewhere.

Important Restart your computer don’t just turn it off and back on.

Restart your watch

You can now open GWD and when you try to run on device it will force a new acknowledgement of the RSA key so be looking for it and acknowledge it.

You however will also need to OK the RSA key next time you connect via WiFi

Samsung Developer Program

Hello Ron,
“a small step for man” :slight_smile:
I found the “Reboot” function of the watch.
I did a reboot of phone, watch and pc an tried to reconnect (developer options, debugging, sdoverbt everything activated).
But unfortunately same result. No RSA KEy or any other message showed up.Anmerkung 2020-05-01 170801

Then i tried to remove the mentioned files. Althoug GWD created new files, it says now “no compatible device found”.
Anmerkung 2020-05-01 173818
I will restore the old files from backup.

Still no connection to the watch. I´m running out of ideas…

Take Care, stay healthy

You just need to create a new Distributor Certificate now that you are connected. You see the Watch in the window it is connected.

That is the issue now.

Samsung Developer Program

Hello Ron,
but i just see the android phone SM-A320FL , not the watch.
Is the watch really connected?
After removing the old sdbkey files no connection was possible. So i restore the old ones, right?
Why do i need an new distributor certificate?

Thank you.

Regards, Sascha

I forgot you had already connected with WiFi before you won’t need a new Distributor certificate.
The sdboverbt app says it is connected to your watch and the computer. ’

Every time you reboot it forces you to accept the RSA key. You need to acknowledge the RSA key and it does not stay but for a few seconds. You need to be vigilant I just don’t think you are keeping the watch active and watching it like a hawk. Are you wearing the watch when you connect?

Samsung Developer Program

Hello Ron,

in have to connect the watch via smartphone and usb, because my pc in connected to the wifi router over ethernet. The pc is not in the wifi.
The watch is not connected :frowning: I can see only the phone, not the watch and when opennig the distributor certificate it says “no device connected”.
No, i dont wear the watch while conecting. It´s on my desk. Now that i know about the RSA Key i really watch my watch. But the damn key doesn´t show up !?


Wear the watch the RSA key only shows (at least for me) when I’m wearing it and keeping it active.

That may be the issue. Again Reboot before trying as it may have gotten set to do not accept from other attempts.

Samsung Developer Program

Hello Ron,

i finally was successful! I found the problem.
I had on my watch a watchface from galaxy store installed. The RSA Key showed up just for a millisecond. Hardly no chance to see.
I set the watchface back to the original Samsung Tomcat watchface, and the RSA Key showed up and stayed.
It seems the other watchface forced the RSA KEY to dissapear.

A very long topic, but now i made it!

Thank you very much Ron for your time and your help!!

Take care

Best regards,