SDB Command Error

I keep getting this error when I try to test an update of my watch face on my Galaxy Watch. All of this is foreign to me. How do I fix it?

If it helps, I have tried updating both my Author and Distributor certificates, with no luck.

I’ve also tried connecting via SBDoverBT, but that’s not working either. I have no trouble connecting my phone to the watch, but when I click on my phone under Run on Device on GWS, nothing happens.

Hi Jereed7

Since you are connecting to watch in order to generate a Distributer Certificate you are connecting to the device fine.

This is a confusing error message. When you first connect to your watch a pop up is displayed asking you to accept an RSA Encryption Key.
You have about 15 seconds to respond or it closes and doesn’t show again thinking it was an attempted hack. Because it isn’t accepted you can’t send the Distributor Certificate and times out, that is the time expired, not your certificate.

Hold down the power button until it says rebooting that will force a new RSA Dialog and not lose any data on your watch. Then the next time you connect observe your watch closely and accept the RSA Encryption.

See FAQ @23 point 4

I think when you use SDBoverBT and select the device at that time the RSA Connection pops up but it has been years since I connected an older watch so It also may not happen until you select the device in Run On Device.

Hope this helps.
Ron

Hi Ron, thanks for the response.

The issue is, I’ve tried rebooting the watch and it’s still not giving me the RSA Key. I am looking closely to make sure I don’t miss it, but nothing pops up.

It’s slightly irritating because I’ve updated this watch and this particular watch face several times before. I didn’t change any settings so I don’t understand why I’m having trouble now.

You are on Windows right? If not there is a totally different issue.

in the C:\users[uername]\ folder is a hidden folder .tizen are two files
sdbkey
sdbkey.pub
rename or delete those files
Restart computer (don’t just turn off and on but use restart to clear any cache)
reboot your watch press and hold power button for about 15 seconds until it says rebooting

I’m sure you did this but just to be 100% make sure Developer Options are on and debugging is on sometimes they get turned off in an update.

Wait a full minute to be sure your wifi is fully connected to both pc and watch

set your watch face to a factory installed watch face.

Launce GWS and your project and select run on device. Observe your watch it should pop up an RSA encryption key acceptance pop up or for older devices an allow debugging pop up.

Ron
Samsung Developer Relations

Thanks Ron, I will give all of that a shot this evening. And yes, I am on Windows.

I am also having the same Issue. Did you get any solution?

PrepaidCardStatus

Make sure you have the same issue. For a Macos Catalina or newer you need to contact support and get a newer version of SDB the one that shipped with GWD 1.8 /GWS 2.x and newer is the wrong version.

On a Windows machine it is usually the designer needs to tweak something but if you can connect to generate the Distributor Certificate then it is 90% going to be the RSA Encryption not being accepted.

If you can’t generate the Distributor Certificate then it is a different issue.

Ron
Samsung Developer Relations