No connected device to generate distribute certificate


I own a Galaxy Watch 3 and I’m trying to run a watch face on it. On the top right, in the Run on Device Section, it shows as connected. But When I go to generate the distribute certificate it shows as No device connected. And I also always get the Can’t reach this page error. Tried several times, always with the same result.



Did you enable developer options in your watch? (Settings > About Watch > Software Version, tap on Software version 5 times)

If you get the DUID in the dialog box for the Distributor Certificate and get the Can’t reach this page there are a few things that it could be.
Windows 7 is not supported if you are using that.
Chrome is not the default browser it sometimes rejects other browsers.
One the seller portal server is off or under service or that it can’t connect to the server that is something that is resolved in a few days.

Samsung Developer Relations

Hi Ron,

I’m using Windows 11. And I don’t get any DUID, it simply says that there is no device connected.


See FAQ 23 on the GWS FAQ there are several reasons this could be happening. Once you connect to the watch when you go to create the distributor certificate it will show the DUID in the form.

Note that with Galaxy Watch3 and Galaxy Watch Active2 you can not connect using SDBoverBT you have to do it via Wifi.

Hope this helps,

Samsung Developer Relations