Notice of new Beta version 1.3.8 (Oct 12, 2022)

Thank you for feedback. Let me know more detail of your issue.

  1. PC information
  • OS and version
  • CPU info
  • remaining storage capacity
  1. To analyze it, please share the log file in your PC.

Window : C:\Users{User}\AppData\Roaming\watchfacestudio\dump\main
macOS : /Users/User Name/Library/Application Support/watchfacestudio/dump/main

Thank you

The triple color style is a nice addition, but it would be more useful if it is an independent 3 sets of color style customization (Or maybe we can dynamically create the color set). And treat it just like image styles that can be grouped into set if it needs to be a color combo combination. And also the label can be renamed, not just “Color”.

An additional limit for image styles to more than 10 is also a welcome addition. Usually, my watch face had up to 20 styles on Tizen.

Also, a random number generator (random()) on the tags would be nice to create a more dynamic watch face. Similar to Math.random() on Javascript.

Thank you,
USA Design

3 Likes

Thank you for feedback.
This behavior is the same in public version which was distributed, not Beta version.
But you want to build with public version only, so it seems inconvenient because Beta version and public version cannot be used separately at the same time. We have fully verified Beta version, but we used the name ‘Beta’ for your additional general usability check.
We will make it possible to update to public as soon as possible.
Thank you

2 Likes

I would but it seems i cannot send a private message in order to share it.

@r.liechty_SDP
Can you help me with this?

The update to Wear OS One UI 4.5 was installed on my Galaxy Watch 5 pro on the 11th of September. I am very sure that after that update I was (still) able to select barometer as a complication. So I do not think that this update to Wear OS One UI 4.5 is related to this ‘glitch’.

EDIT: this is really odd. I changed the language on my phone (Galaxy S21 FE) from Dutch (NL) to ENG (US) and a lot more complications appeared as available (including the barometer). After having switched back to Dutch (NL) I can still select all the complications I could in ENG. So, for me this issue is resolved. However, it seems to be a bug. Where can I report this bug?

Hi Sheido,

I sent you a private message so you can either send me the log and I can forward it to Catherina or you can upload it to tech support and they will pass it on to Catherina.

Ron

@peter2

I’m curious if this was just a matter something in the Watch or the Wearable App when you changed languages.

In the future you can report bugs in the Samsung Members app. Even if it is a Wear OS issue they should handle it. If it was a Wearable App then for sure it is Samsung’s bug. If this was WFS issue then Catherina has seen it and you don’t need to report it as such.

Ron
Samsung

Hello,

The color style customization order always stays on the first order, although we already set the order on the customization editor.

And also we need to set the target API to the latest version, currently, the WFS target API is 30. Google now requires the minimum target API to be 2 versions from the latest, so it will need to be updated soon.

Warm Regards,
USA Design

Thnx Ron. I am not aware of that Samsung Members app but will search for it and report it, just to be sure that it is reported wherever it needs to be.

I have stumbled on something strange with the new beta.
I was trying to use textFormat function on [SEC_MSEC] tag, like numberFormat(00.000,[SEC_MSEC]).
For some reason I could not reach any formatting not even any real time msec values to be displayed in preview.
When I isolated the [SEC_MSEC] in the text field to see what it actually returns, there was comma in place of the decimal point. In my country we do use decimal comma so it first did not feel strange, but then I realized, this may cause variable mismatch for the formatting function and cant be processed right.
image

2 Likes

Looks like the format is localized, when I tried it in the US I did get the decimal dot but I think you are on to something.

Ron
Samsung Developer Relations

Bug: Image opacity doesn’t work on actual watch (Watch4 Classic)

It’s working on my end with GW4 classic using a full black image dropped to 40%. It’s a bug even in the older version of WFS. You just have to remove it and reupload it again.

1 Like

how about to use numberFormat(“00.0”, [SEC_MSEC]) ? The text format string such as “0.00” or “#.##” needs to be wrapped by double quatation. It seems work well on my end.

Thank you, those quotation marks plus outer pair of brackets made it work the way I intended.
(numberFormat("00.000",[SEC_MSEC]))
Now can the MSEC part be somehow reset in the preview? I mean with moving the time slider I can only adjust the MIN or SEC part of time, but the decimals do not change at all. When I hit the play button, only the tenths change like 00.200, 00.400, 00.600, 00.800, 00.001, 00.201, 00.401, 00.601, 00.801, 01.002, 01.202, 01.402, 01.602, 01.802, 02.003, 02.203… It would take 100s of running preview to let the thousands to get to .000 again.

Complications Settings - Default Provider:

Please update the “Sunset / Sunrise” complication ID app to those released on ONE UI 4.5. The current one, under default provider, no longer works.

I had already reported this issue on September 15th.

Thank you.

Customizations:

When we set customizations such as background, graphic elements, etc. on WFS 1.2.7, we can give a name to those customizations such as “Hands”, “Time Color”, “Date”, “Stripes” etc …

Now, on WFS 1.3.8, it is set as “SET 1”, “SET 2”, “SET 3” etc …

Is there a chance to still get the custom names?

Thank you.

You can rename them in the Customisation Editor

@stismo

I hadn’t noticed it. Thank you.