Release Google Play Store

Hello. Today I have released a WF in the Play Store, but in the list of supported devices my watch will be grayed out and you can not select it. What did I do while wrong. How can I eliminate that and upload an update. Honest … The Samsung Seller Store was much easier!


if i understood your problem correctly.
Go to : Play Console / View app / Advanced Settings / Release Types and Add pictures of your watch face and wait for the review result.

Thank you, I also did not know about this, maybe why I am still yet to make a sale…

I have forgotten using extended settings release type Wear OS to add. It is still checked. But I do not know if it lies. At the moment I have 0 active devices in the dashboard. The device check is not yet completed.


Is there anyone who can help me? There must be a guide successfully to publish a watchface in the store

I have exactly the same problem. I’ve contacted other developers to ask them if they are in the same situation or not and they are!! I contacted Google Play Store Console help center and didn’t receive any response. I really don’t know what to do.

Hi, I asked Matteo Dini (MD) by mail and get an answer. Thanks again Matteo Dini … you are great! Here his answer.

  • First of all, make sure the watch faces is set as “Wear OS” under configuration> advanced settings → release type.

  • Then, check if the watch face (file release) has been validated under the release type section.

  • Third, always remember that Google performs separate validation of watch faces.

  • Validation of images and shop description

  • Validation of the watch face file

    Yesterday I still activated Wearos under Configuration> Advanced Settings → Release Type. Now I have to wait. Check if you have activated it!? If you did not activate it, then click Add Release Type and then on Wearos. Then you have to wait the test is completed by Google.

Thank you very much for the information. Google made Play store console complicated I guess.

1 Like

So after review, Wearos devices are enabled in Configuration> Advanced Settings → Release Type. All available devices are active and the watchfaces are downloadable in the store. So that was the mistake!