Run On Device not working consistently (hardly ever)

I have read the posts on this forum about how to connect my 5 Pro to WFS, and yesterday, after a couple of hours of messing around, it suddenly started working. But this morning, I am back to square 1 and nothing I tried yesterday seems to be working. All the posts on the topic are a little old, so can someone please let me know if there is an up-to-date definitive guide to loading self-designed taches onto my watch?

Just so you know:

  • wifi debugging is on on watch (have also tried BT debugging), usb debugging on on phone
  • phone and watch are on same wifi and both on fixed IPs
  • firewall disabled on PC
  • have tried revoking debug authorisations on watch
1 Like

My biggest issue was always the missing WIFI connection. If you have an active Bluetooth connection, WIFI is off (AUTO) even when you had it tuned on. So open wifi settings on your watch check the wifi is connected and keep that screen active/open. With that, search your Watch Device IP. Give it a try.

You can no longer run on watch using Bluetooth connection the wear app that did that is not compatible with Wear 3, you have to run on device using WiFi.

Wear OS is smart and will turn WiFi on when needed when it is set for Automatic. You should not need to turn BT off or Turn WiFi on. Just turn the ADB over WiFi on.

@zombie I think I know the problem.
A be sure when you try to connect you OK it on the Watch it won’t show up on WFS until you do
Also it won’t show up the first time on WFS

Select run on device
It says nothing found
Enter IP address
OK on the watch and select do not ask for this computer again
Run on Device
click on the IP address again
and then it shows up.

Let us know if that doesn’t do the trick.

Samsung Developer Relations

I also agree with you.

I have noticed that if bluetooth is on while running the build on watch . A lot of times sending watch face to the watch fails.I always try to switch off bluetooth and only wifi always on by going into setting of wifi till it connects to wifi.

The connection has many times been unstable with WFS for me when bluetooth is ON. other way around when only wifi is on there are zero issues for me.

1 Like

I’ll add this to my notes. I’ve never had an issue with BT being on but I am not a hard core Run on Device user.

Samsung Developer Relations


well i have also noticed Ron that if bluetooth is On 80 percent of the time wear os will automatically turn wifi off.

as i understand this is default behaviour of wear os and most of times my watch wifi was switched off during a run on device when the bluetooth was kept on.

When Watch 4 first came out even having WiFi off, turning ADB WiFi debugging on and forgetting to turn it back off would eat the battery quickly. However, I’ve forgotten that a few times over the past year and while it does use a bit more battery it seems to be shutting WiFi off when not in active use.

I think that verifies your idea. I just hadn’t put 2 and 2 together.


I have tried this dozens of times. I did manage to get it working for 20 minutes at lunchtime, but now, nothing. At lunchtime I got the message on my phone asking me to authorise connection, and then it worked for a while. But I am trying now, and no amount of repeat the instructions above will bring up the message on the watch authorising the connection. Revoking debugging authorisations does nothing.

There just doesn’t seem to be any consistency to it.

Just to be sure you don’t have another version of ADB on your computer. If you do then that is the problem.

You shouldn’t need to re-authorize unless you restart your computer.
Revoke should have worked may not have worked if you didn’t restart your computer.
Try rebooting your watch by holding down both buttons until it says rebooting. (do not hold down after that or it might reset your watch). After rebooting start anew with ADB Debugging.

Samsung Developer Relations

well yesterday I tried everything, no joy. Today I tried talking to the watch directly using “adb connect” command as I wanted to side load my design. COuldn’t reach the wATCH THAT way either. So disabled adb on watch then reenabled, and it asked me if i wanted to connect. now all working fine, though i have had to go through this cycle again since then, at least it’s working.

It maybe as Osman said that the WiFi is disconnecting. I don’t know but if you notice a pattern can you post it. I like to keep notes of this for others that have issues.

Welcome to the Designing club !!!

Samsung Developer Relations