SAP authentication not matching

I’m using Tizen Studio to compile my companion application with Tizen3.0 compiler (Long story short, there is no way to use the emulator on newer versions).

So, I downloaded the SDK from here: Galaxy Accessory - Build | Samsung Developers

It’s version is 2.6.4 and I could install the Android part on my phone, and the Tizen part onto the watch from this folder: Consumer(Tizen)_Provider(Android).

I want to make the connection secure, and in this sample application there are parts commented out which responsible for the authentication. So I went ahead and removed the comments, and instead of immediately acceptServiceConnectionRequest, I call authenticatePeerAgent.

That’s fine, onAuthenticationResponse is called, but fails to validate authToken: it’s size is not matching with Android application’s package certificate’s.

And I can’t import Android’s certificate or keystore, because I don’t have that option in Certificate manager:

image

I searched for more and found this: Galaxy Watch - Build | Samsung Developers, but this is also ridiculous, it doesn’t even have any main function. :slight_smile:

So guys, what would you recommend me to make the connection with SAP secure?

I feel how Samsung thinks on “simplify implementations” :smiley:

(Source: Galaxy Accessory - Build | Samsung Developers)

I’ve read in many threads to open a ticket, so I also did that: https://developer.samsung.com/dashboard/support/32312

Don’t know if it really matters. :thinking:

Hello danergo,
Did you select the option “Samsung” as the type of the certificate?
According to this link, the advanced option should be there, if you select Samsung as the type.
Please go through the link above and find the figure in Create a New Author Certificate section.

Thank you.

Hi!

Sorry, if I was not polite. My issue was indeed that I haven’t selected “Samsung” as type of the certificate.
However with my Certificate Manager, there was not possible to choose the type of certificate: it always defaulted to “Tizen”, and the there were no advanced options.

I had to reinstall the whole Certificate Manager to resolve this. After that, I got back the type chooser, and in case selecting “Samsung” I had the option there.