[SOLVED] Unable to run Tizen Studio app on watch

Hi there!

I am having problems when trying to install a simple app I made with Tizen Studio. I always get error -19 when installing at the “[Installing the package…]” step.

I tried both Windows 10 and macOS Catalina and am still getting the same error. I’ve attached screenshots below of the error pop-up and console.

What I’ve already done:

  • Created an author and distributor certificate with my watch connected
  • Approved debugging prompt on watch
  • Restarted both Tizen studio and watch
  • Used a different platform
  • Enabled “outside sources” on the Galaxy Wearable app on my phone
  • Installed Certificate and watch “extras” in the Package Manager

Any help would be greatly appreciated.

Thanks!

errorMessage


I figured it out!! I was getting a parsing error because I was making a Wearable v5.5 project instead of 4.0.

There are probably one of two issues. First is you did not accept the RSA encryption key when you first connect to your watch. You have to do that the very first time in order to transfer encrypted content. And I think that is the error you are seeing. keep trying to connect with the device manager if you didn’t remember accepting the RSA key previously.

Another error is using a Tizen Distributor Certificate and not a Samsung Tizen Distributor Certificate. Check your certificate profile to be sure it is Samsung Certificate.

Hope that helps
Ron
Samsung Developer Program

1 Like

Hi Ron

Thanks for the response. I definitely accepted the RSA. I remember doing it. As for the certificate, I don’t get an option to create a Samsung Certificate in Certificate Manager. I have installed the Certificate extension from the package manager and everything seems to be there, but when I click the + button, I don’t get to choose between Tizen Certificate and Samsung Certificate, as I have seen in screenshots. What do you suggest I do?

@r.liechty_SDP I fixed it!! I was getting a parse error because I was making a Wearable v5.5 package instead of v4.0.