I’m trying to follow the guides to publish an app into my physical watch but I’m getting this error:

Cannot install application.

Command: /usr/bin/pkgcmd -q -i -t "NativePkg" -p "/opt/usr/apps/tmp/" -G; echo cmd_ret:$?;
Management: Check whether the package is modified illegally. If there is an installed package which has same name and different signature with your package, you can receive this error return also.

How can I solve this?

I just downloaded Tizen Studio so I’m running the latest software

Thank you

Probably you already have installed app on your device and now you try to install the same app-id but signed with another certificate. It must be the same cert all the time or first uninstall the app.

Hey, thank you for your answer. But this is a brand new watch, and this is the first time I’ve even installed Tizen Studio. So it’s impossible that I have installed something in the past

You need to have a Samsung Tizen Distributor Certificate to side-load onto a Samsung Device. Do not have both a Tizen distributor certificate and a Samsung Distributor certificate that won’t work just the Samsung Distributor Certificate.

You probably want the Samsung Author certificate as well. I don’t think it matters when you side-load but it does when you upload to the store.

If that isn’t the issue did you accept the RSA Encryption key when you first tried to install the app? If not then you can’t read the signature and it fails.

Samsung Developer Program

Hi Ron, thank you for your answer.
This is what my certificate manager looks like:

I don’t see anything mentioning Samsung. How do I get that? I was just following the getting started tutorials.

I’m still very far from going to the store, I just want to start looking how all this works.

I think I did accept the RSA Encryption key, but is there a way to double check?

Thank you

You need to create Samsung certificates to side load onto the device. Those are only useful for running in the emulator.
See this page

The Tizen SDK used to come with Samsung Certificate extension in the Watch sdk but it is an additional step now. Read the full instructions on installing and enabling the Samsung Certificates.

Once you have the extension enabled delete the old Tizen one and start again.

I think you did accept the RSA Encryption to get as far as you did. I think you get a timed out error if you hadn’t.

Also unless you have Galaxy Watch3 you need to build for Tizen 3 or Tizen 4 not Tizen 5.5

Samsung Developer Program

1 Like

I do have a Galaxy Watch 3.
Ok, I’ll check that article and come back with hopefully positive results.

Thank you Ron!

A Samsung Gear S3 Frontier to be exact. Is that ok to be using 5.5?

That worked Ron! Thank you so much!!

Really thanks Ron for useful hint ! :+1:

Gear 3 run Tizen 4.0 They might get updated to Tizen 5.5 in the future but build for Tizen 4 or older for now.

Samsung Developer Program