Stuck on "Generating Author Certificate" Screen


Screenshot 2021-06-16 222938

Hey,
I have recently installed Galaxy Watch Studio to create a watchface for my watch. Everything worked fine until I tried to export my watchface to my watch. I was able to create a Distribute Certificate, however when trying to create an author certificate, it was stuck on a screen saying: Generating Author Certificate…
When I tried exiting the window without it being fully completed (not that I know how long it would have taken), I tried exporting my watchface but it just gave me the message saying something of the sort: An error has occured. See log files.
Upon inspecting my logfiles, I have no idea where the issue lies.

I have attached all files to this post

I forgot to add, that after trying to export the watchface the application freezes and or crashes

I’m a bit confused.
You can’t build and Run on Device unless you have a Valid Author Certificate and Distributor Certificate. So I am guessing that you are crashing when building not when trying to sideload to your watch.

Look in the C:\users\USERNAME\GearWatchDesigner\Keystore to see if you have an Author.p12 and Distributor.p12 files. I would bet either they don’t exist or are corrupted or each have a different password.

Since you haven’t uploaded to the store I suggest you create a new Author Certificate first then a Distributor Certificate and be sure to use the same password for The Distributor Certificate as the Author Certificate.

Restart your computer (don’t just turn off and on but use restart to clear any caches.)

Create them in GWS.

When you go to create the Author Certificate There is a captcha that you have to do but often isn’t seen and no obvious scroll bar. So when you hit enter to proceed but it won’t proceed just repeats the error message where you can’t see it.

Ron
Samsung Developer Program

My Problem is that whenever I try generating a new Author Certificate, it stays on the “Generating Author Certificate…” Screen without progressing. Therefor I am guessing that the file never gets fully generated and therefor gets/turns corrupted

Did you scroll down and submit the Captcha? Or just hit Proceed. It just repeats the captcha error (out of sight).

Ron

I am unsure what Captcha you are referring to.


For reference, this is what it looks like for me to create a new Author Certificate. In none of the steps do I come across a Captcha. Sorry if I am missing something here

No I’m missing something they changed from the Captcha to 2 stage verification.
From the page shown it will ask you to create password and another page f for personal information, (or the other way around) and then this screen pops up.

You need to scroll down and enter the verification code sent.

If you don’t have two step verification it has something different.

Ron

I completed the 2-factor authentication. But the problem lies in the step just following the 2-factor authentication. When I complete the login and the 2-factor authentication, it brings me to screen saying “Generating author certificate” (which I previously shared in this discussion). The problem lies on that very screen as it never finishes the process and even after waiting an hour, the Author Certificate is never fully generated. (Sure It generates the file, but as I have to cancel out of the process before it ever finishes, the file is corrupted and crashes the program when I try to load the Watchface to my watch.

hmm, As soon as I entered the verification code it proceeded on. Go to the seller portal Enquiry 1:1 support and send a screen shot with each step. include the time when you were doing it as well.
Do not use FireFox as the default browser it does not play well with the store. Make there are no popup blockers for the site.

If you don’t get a satisfactory solution by Monday let us know. I will try to intercede for you.

I am sorry you are having an issue. Generally this is extremely easy to generate.

Ron
Samsung Developer Program