There is no Bangkok in world clock

There seem to be cities that do not exist in world clock. One of my customers wants to choice Bangkok, but he can’t find it. As expected, I can’t find it either. How can this be solved?
Can I fix it in the next update? Or do I have to wait for the World Clock app to update?

Hi. World Clock app complication for Bangkok is working fine for me.


Not this, but if you use short text complication, it comes out as a city code, but I don’t think Bangkok comes out.

This will depend on the clock app on his phone.

Samsung Developer Relations

He and I are using Samsung phones. Bangkok comes out on Samsung Phone’s watch app. Of course, it comes out on the watch app. But I can’t find it in the complication.

I also tried to add Bangkok in world clock using complication. But don’t find it in listed time zone.
I would recommend you to submit a report on Samsung Developer Support regarding this issue

You should open the Clock app → World Clock on the phone and add Bangkok there.

Samsung Developer Relations

I’ve already done that.
However, it also does not appear in short text complication.

There was a similar problem with Galaxy Watch Studio exemplar cities (ICU Format VVV) and The GWD team had to remove that option because of the number of complaints they received.

Make sure you are doing it correctly
tap on World Clock
scroll to manage on phone
select Bangkok on the phone
My world clock had ended I had to tap on it again
it timed out and I had to tap again
It took me at least a full minute until change showed on my watch (It seemed to wait for a weather update)
After clicking on Change it showed on the watch.

If this isn’t working after that let me know. I can at least ask around.

Samsung Developer Relations