Time Zone not working

When adding another time zone using drop down menu - the display shows the same time as the main watch

Hello,
Did you mean on Watch face Studio’s RUN window?
In RUN window the time is not show for your selected time zone rather it shows the time which we can change for RUN preview.

But for watch it’s working.
I have added two different digital clock, one for local time for which I have set the properties “Sync with Device” and another for London time zone(London, GMT+0). After deploying the design on my watch it working perfectly.

Thank you for your reply. I realise that it does not change in the run studio but unfortunately it is not working on my watch, even though i have set it up as you have.

You can use complication to set a different time zone in your watch. By using world clock you can select a different time zone with the help of complication. May be this will work in your watch.

I see in your other post that you want UTC not GMT (it has no daylight savings time) it is used by pilots, etc.

If you select Accra Ghana it is GMT and does not have DST and will remain on UTC.

I’ll add this as a feature request, it was something that was added for Galaxy Watch Studio

Ron
Samsung Developer Relations

Ron

Thank you, I tried your solution and it appears to work…much appreciated. If you could put an UTC option it would be great.

Once again, many thanks.

Tim

We have added it to the feature request.

Ron