Watchfacestudio Watch 5 Pro Alternate Time Zone lagging

Hi All. I am trying to build a face for my watch 5 pro. Everything is working within acceptable norms except the digital watch with an alternate timezone.

I live in Singapore. Have my watch set to GMT+8 which is the local timezone. I put in a small digital watch to display the time in India and set the timezone to Kolkata - GMT+5:30

It displays fine but lags by an hour time to time. Example: time in Singapore is 09:30. The digital face should display 07:00. However it was displaying 06:00. Switched faces and came back and everything is updated.

Works for a while and then lags again, always on the hour part. Have tried to delete and reinsert the digital clock. Have tried using both 24h and 12h display but nothing helps.

Any thoughts on this please? Super annoying. Thank you very much.

Edit: to add. The error is in the first 30 minutes of the hour. Second 30 minutes the hour hand catches up. Almost like the time zone is incorrectly specified and is lagging/leading by 30 mins on the hour hand.

Most probably Samsung Clock is using complication refresh interval of 1 hour or 30 minutes. You can try Complications Suite - Wear OS - Apps on Google Play
World Clock complication, it looks better, have some additional settings like leading zero / 12-24h and uses different complication refresh approach which also uses less battery and updates instantly.

Nice plug for your product. But that is an irrelevant and useless answer tbh.

I read it wrong, you are trying to use digital element in watch face studio.
My new answer is: use a custom complication instead of digital time element.

1 Like

Thanks. Will try and come back.

This looks like a bug to me. It could be because it is set to GMT+ (which is in Daylight Savings time) instead of UTC+ If I can verify it I’ll report it as a bug. Not having UTC time really annoys me.

Ron
Samsung Developer Relations

Tried. But it doesn’t let me choose a time zone on wfs. And on the watch it displays the zone but again, doesn’t register my choice.

Is there something I can do to assist so that you can report this bug? Really annoying me :smile:

So the world time complication works. However I need two instances - one in normal mode and one AOD.

When I tap to change the time zone, one of them - usually AOD gets updated. However the normal one stays on the stock - local.

I tried to keep this as one single complication but then the layering gets messed up and the hands sweep under. Or the complication is not visible as it gets hidden under the last layer.

Is there a way of having the same complication in AOD and normal but both linked to the same time zone instance so I don’t have to select twice?

Thanks for the help and apologies for all the questions. Hopefully the text tag bug gets resolved and makes life easier.

Thanks again.

I will check this soon I should be able to duplicate it.

Is there a way of having the same complication in AOD and normal but both linked to the same time zone instance so I don’t have to select twice?

I don’t think you can with different layers and all like you want.

Ron
Samsung Developer Relations