Time Zone Selector Bug

I might have found a bug in 1.8.1 for the time zone selector.
So when i added the Time zone selector on a digital clock , everything worked good (I just wanted to try it out).
Then i used the action tab to take it out , and the saved it, created a new .tpk and downloaded it to my watch. Guess what the time zone selector was still there.
So i tried it again 3 more times and ended up with the same result(it would not go away)
So finally I deleted the digital clock and created a new one and then it worked (Time Zone Selector was gone)
Somebody needs to verify this , or maybe someone has already reported this , I am not sure
Ron , this might be a bug.

Hi Malcolm,

I couldn’t duplicate this.


Hi Ron
There is a bug,
Put the weather location, temp and humidity.
follow the same procedure
First time time zone selector .
second time without the time zone selector (saved with a new .tpk )
upload to the watch . You will see the time zone selector option on the watch

HI Malcolm,

Did you try this with GWS 2.0?

Samsung Developer Program

Not so far , but i will asap

Hi Ron
Tested on 2.0.0 .
Result is the same .
So I tried taking the Location/ City (weather)name out.
Guess what , problem solved.
For some reason the time zone selector option is not working properly with the
city/location option from weather.
Definitely a bug in both versions with weather watch faces

Hi Malcolm

I noticed that turning off the Set as a Button did not force a save to rebuild and I got the timezone selector again as you said.
Adding a text box or something else such as removing the location forces a save and then it is updated correctly.

I’ll open a bug report on this.

Samsung Developer Program

1 Like