Unable to connect 5+ to GWS 2.0.1_beta but connection OK in 1.5.7

Upgraded? from older WFS 1.5.7 to latest GWS 2.0.1_beta. Still able to connect my Galacy 5+ watch to WFS via wi-fi but not able to connect using GWS.

When I start “Run on Device” in old WFS, it asks for Pairing Code and Pairing Port witch I find on my watch, but GWS doesn’t ask for these, only the IP address. I have tried entering the IP address and adding a colon and the port (i.e. but that is not accepted.

I have gone through the Connection Guidelines help PDF but still no luck.
My watch is connected to my access point (shows it on the list of connected devices). I have made sure that Debugging is On on my watch and have tried rebooting the watch.

Any ideas? Help would be appreciated as it looks like the newer version of GWS is an improvement otherwise.

You cannot connect the GW5 with GWS. GW5 has as operating system Wearos and GWS is for Watches with operating system Tizen

to add to what @SGWatchDesign said

GWS 2.x is for Galaxy Watch 3 and older. GW4,5 and 6 run Wear OS and use Watch Face Studio.

If you are having an issue connecting WFS 1.5.7 to your watch we can help on that. It is complicated and says fail to connect when actually it is just waiting to connect.

Samsung Developer Relations