Small question about WFS 1.3.13 and Galaxy Watch 6

Hi All,

Can anyone confirm me that the new GW6 can’t link to WFS 1.3.13 for the transfer of the “old” watch faces?

I did several tests but it seems that it cannot be connected.

I was hoping the opposite since the watch faces are compatible also on Wear OS 4.0



Ok, I just realized that it is not possible to link WFS 1.3.31 with the new GW6 because additional data is required:

IP Address
IP port
Pairing codes
Pairing port

We look forward to receiving updates on the “memory budget” issue to update the watch faces on the Play Store.

1 Like

You see those with GW4 and GW5 too with the new tool. It happens when you don’t wait long enough to OK the file transfer from computer to watch.

I don’t know why but this is a recent thing and It takes a long time (like almost a minute) for that OK to pop up. It didn’t take that long before. I had forgot about it because I had selected don’t show again.

Samsung Developer Relations

@Matteo_Dini did you happen to find a solution to this?

I got my GW6 test device today and I’m having the same issue. Just can’t find a way to connect the new GW6 with WFS 1.3.13.
Also, no matter how long I wait for the “OK” to pop up (I tried waiting 2-3 minutes with various settings each time), it doesn’t show up on the GW6.

ADB debugging is allowed, watch has been rebooted, I even tried with “Wireless debugging” turned on (which wasn’t required on GW4), and the GW6 just won’t connect to WFS 1.3.13.
I’m trying the same “Run on device” process that works instantly and without issues with GW4.

Worth noting - There’s an option “Debug over Wi-Fi” under Developer options in GW4, but this option doesn’t exist on the new GW6 for some reason. This might be the issue.

Can it be that it’s only possible to connect the new GW6 with WFS 1.4.20, and not at all with 1.3.13? :face_with_raised_eyebrow:

Hi @enkei_design, What worked for me:

  1. create hotspot from your mobile (I have poor wifi signal :smiley: ) and connect both computer / watch to it.
  2. developer options → wireless debugging → enable → pair new device
  3. command line (maybe works from WFS, don’t know, not using it )

adb pair

when prompted type Wi-Fi pairing code

After connection is successful, you should see your computer listed here


now CMD once again , this time, use IP address from top main section, notice that the port is different and we are using adb connect now (not pair)


adb connect IPADDRESS:PORT
adb connect

Now you should see connection successful, you can check this with

adb devices

After computer is paired, it is only needed to connect to the main IP:Port (Not the one from the pairing screen), it will also work on any Wi-fi network but you need to confirm this on the watch.

What’s unfortunate for me, maybe not for others is that Wi-fi debugging is turned off every time there is a drop in Wi-fi connection (maybe because of battery saving purposes). This means that for example every morning you need to go to dev options, enable wireless debugging, check port because port is always different random number, and connect to it.


Because WiFi debugging kills my battery I would be pleased to see this happen. :slight_smile:

I’m going to bookmark your reply I think it may come up again.

Samsung Developer Relations

When I finished work in the evening, I set airplane mode. In the morning, I turned off the airplane mode, the watch connected to Wifi, then I just pressed the predefined command and I could test the faces on the watch. In the morning I always found almost the same battery level. During the day, I keep the watch near the charger all the time and recharge it from time to time. When I use the watch mainly for watch face testing purpose, the battery does not bother me at all :grinning:

With GW6, process is a bit more complicated. But nothing terrible.


After you have connected the Watch to the WIFI network and activated the developer options, go to debug wireless … Then pair new device, from there you will get Pairing code and Pairing port (after the colon). While the main port is IP address are in the previous menu.

Here go to developer options

Debug wireless:



In this case IP address: and port 44289

Here instead Pairing Code 494306 and Pairing Port 33453 (you have to tap on “Associate new device”):


You need these 4 data to connect the Watch to WFS.

BTW, you can NOT connect the GW6 to WFS 1.3.13. Only 1.4.x or higher*

Reading other users’ answers, it seems that it is possible to link GW6 to WFS 1.3.x via shell.


i believe as soon as Samsung Watch 5 Pro and Watch 4 Classic are updated to Wear OS 4.0 This procedure will also be valid for them. It is bit of unconveyneance pairing every day andother option not switch off watch and keep it on airplane mode at night when sleeping seems better off. Then re-pairing every time.

Thanks to all for above information. This means per force when wear OS 4.0 comes we have no option but to upgrade from 1.3.13 WFS to latest WFS 1.14.20

and does this also mean we have to update all our watchfaces with 1.14.20 to be compatible with watch 6 series??

1 Like

Hi, this is Isaac.

This method uses the adb command and requires some DOS knowledge.

The command to use is:

1.adb pair (The last 5 digits are the pairing port number.)

2.adb connect (The port number is 5 digits, and it is a wireless debugging number.)

To execute this command, you need a program called platform-tools distributed by Google.

You can search for it, download it in advance, and unzip it.

After that, run the above two commands in the command prompt.

If you pair first, it continues until you cancel the pairing, so you only need to use the port access command for the second WFS connection.

  1. Activate developer mode on your watch.

  2. Enable adb debugging in watch developer mode.

  3. Activate wireless debugging in watch developer mode and connect to wifi. (You can see the ip and port number.)

  4. Press the + sign to register the device. (If you press it, the pairing number, IP, and 5 digits of the port number appear. Do not close the screen, but you must perform the pairing command on the computer while it is open.)

4-1. Right-click on the platform-tools folder that you downloaded and unzipped in advance and click Open in Terminal to open a command prompt.

  1. Enter the pairing command adb pair (This port number is the port number indicated in pairing.) and then insert the 6 digit pairing number.

  2. Connect to the computer using the connection command adb connect (This port number is the port number displayed in Wireless Debugging).

If successful, connected blah blah comes out.

You should now see that the watch name is already displayed before WFS does as usual.

If not, restart WFS and try again.

If you try it and leave a comment if it doesn’t work, we will help you.


You can connect your wearOS4 device to your computer on WFS 1.3.13 in the same way as above.

1 Like

Good old Tizen, I had just to turn on debugging on watch (never turned it off, it did not affect battery drain at all) turn on wi-fi, confirm the RSA prompt and try the connecting multiple times until it worked, but did not need additional tools nor searching for ports and what not. I guess there is all the tightened security in background, but to me on the outside this new OS keeps looking inferior


I have to do this every time?


Yes, at least as far as I’ve seen. A new Pairing Code is created every time.

Yeah you are right. Got my watch today and it’s every time. :roll_eyes: But ok, it is what it is.

Hello, I was unable to connect my Galaxy Watch 6 to Wfs despite following all the instructions mentioned above.
Platform Tools is installed, I am running powershell in the platform tools folder, adb is installed, adb debugging is on, wifi debugging is on, and I am adding a device, but I am getting the following error. I would be glad if you help.

Try using adb.exe instead of the command adb.

1 Like

The pair command contains 6-digit number. Enter 5-digit number and 6-digit number in the pair code.

1 Like

Thank you very much,did it.

1 Like

Many Thanks for your wonderful post.

I was able to pair watch4classic 46mm via adb command line.

using adb connect command i then connected watch4classic 46mm on wear os 4 to my pc.

Watch was not appearing so as per your suggestion i restarted and now watch4 has appeared in WFS 1.3.13

Guess this the only way if using older version of wfs