Unable to detect USB microphone most of the times

Unable to detect USB microphone most of the times

I am developing an application where I need to capture audio from USB microphone connected on the phone.
The USB microphone doesn’t show up in “AudioManager Input Devices” for setting it as a preferred device for input in AudioRecord. Rarely it shows as an input device and am able to capture the audio.
This issue is specific to Samsung phones and works well for most of the other phones I tried. Tested on Samsung A10, A20s, A30s, M10s, S10, S20.
I tired USB pendrive, it gets detected and also tried changing several USB microphones, still the result is same.

The USB microphone is getting power from the phones I tried as there is a power indicator led on the USB mic that turns ON after receiving the power.

Referred following links but couldn’t get my issue resolved

Thank you for participating in the Samsung Developer Forum. However, this is not the correct forum for end product bug reports, questions or concerns. Did you try a soft reset of your device. Don’t do a hard (Factory) reset as that will erase all data but a soft reset could help.

You seem to have reported this to the proper site. You can also report it to your service provider site they often are helpful and can report bugs.

Because end user questions disrupt developer discussion this thread will be removed soon. I’ll leave it say for a while in case someone has also seen the issue and knows how to resolve it.

Samsung Developer Program

I tried soft and hard reset but the problem still exists. This problem seems to be present in range of Samsung phones we tried and seemed developer specific issue hence posted the same here.

Can you please share the link for service provider site where we can post this issue?
Apart from common cases like restart, firmware update, software reset if you can help us reach somewhere where we can directly communicate at developer level please let us know, it will be a great help.

First off I apologize I misread your message, I didn’t read the first sentence. It is a proper developer question.

The devices you list don’t use a standard Audio USB adaptor have you bought an S20 compatible adaptor?

Samsung Developer Program

I will check if the adapter I am using is USB audio, device compatible adaptor or not. If not will try with compatible adapter and get back on this issue.

I tried with the USB OTG connector by Samsung on A20s but still was unable to get the USB audio device detected.
Can you please help us with debugging this issue on listed Samsung phones?

Please open a support request and they may be able to help you.

Sorry for the delay in replying I took a mini vacation.

Samsung Developer Program