Visual Studio Code Extension not working

I tried installing the VSCode extension, but it looks like it depends on a package ms-vscode.csharp which has been renamed by Microsoft to ms-dotnettools.csharp so it no longer works.

There is even a message from Microsoft on the Q&A to the extension mentioning this transition but there hasn’t been an update on the Tizen extension since 2019.

How can we get a new version that works?

Thank you!

1 Like

Same problem here. Since Version 16.7.2 Tizen Extension shows me Android Devices too, and it is no longer possible to install/debug from VS. After 15-18% it stops the install process

Every time i open my solution file (with 40 tizen projects), i ran into a lot of error messages, that tells me, the visual studio has an “unexpected” (what else…) problem with the tizen projects. It is definitively not a problem of VS.

Samsung doesn’t seem interested in attracting .NET developers … :thinking:

You can go through the Samsung Developer Support channel.

In the developer support channel, Samsung provides technical supports for Samsung SDK and tools to the developers. As it is a development tool related problem, I hope this will help you.

There is a workaround to bypass the issue. You will find the solution here and to make it easy I am going to write down it bellow.

You need to modify some files and everything will work fine.

In windows pc go to C:\Users\user_name\.vscode\extensions\tizen.vscode-tizen-csharp-1.2.0 then in this folder edit the file name .vsixmanifest.
In this file, you will find Property Id=“Microsoft.VisualStudio.Code.ExtensionDependencies” Value=“ms-vscode.csharp” this line. Now change the value as Value="ms-dotnettools.csharp"

Now go to package.json file in the same directory and change the following line “extensionDependencies”: [“ms-vscode.csharp”] with “extensionDependencies”: [“ms-dotnettools.csharp”]

I think this will solve your problem before the update.

This seems to affect Visual Studio Code not Visual Studio…