Watch face cannot be installed as a standalone

Hi guys! I made my watch face and the companion app available for internal testing on Google Play. Watch fase bundle was uploaded to the Wear OS only track and the companion app to the Phone, Tablets, Chrome OS track. However, I have a strange problem that companion app is listed as mandatory for installation. Any ideas how to make the wach face independent from the phone app and make the installation of companion app optional? I’ve checked the manifest file for the watch face and meta tag is set to true.

Do you have two different version numbers for your Watch and Mobile apps?

See this Topic for settings

It is pretty long.

Samsung Developer Relations

Thanks Ron! I read it several times. It seems to me we are resolving problems by trial and error, mostly due to the poor Google support and extremely unintuitive Console’s UI. For me, the solution was to clear the Google Play Store cache on the phone. Hope this helps someone in the future.

1 Like

Sorry, but I had to reactivate the issue. The problem popped up again. I have two tracks, Wear OS and Phone, aabs have the same name, their versions are different. I’ve even tried to upload a completely empty companion app, with higher or lower version number, and the situation is the same, not only on my phone. I can only guess the problem is with the manifest file generated by WFS. Or it has do something with SDK versions?


Did you see this tutorial

I think you may be setting the mobile app as a companion app it is not.

In the Wear OS Quality Guide it says

|Companion app|Companion app|WO-P5|For non-standalone apps, ensure that the companion app can connect with the Wear app and allows the user to use the Wear app as expected.

For more information, see Core app quality.|

A watch app is considered either standalone or non-standalone:

  • Standalone: a completely independent app that does not require a phone app for core features, including authentication. If available, a phone app provides only optional features.
  • Non-standalone: a dependent app that requires an app on a phone or another device for core features, including authentication.

Samsung Developer Relations

Thanks Ron, but I don’t understand what do you mean by “it is not”. Yes, I used the exact code from the tutorial you are referring to. When I install the phone app it works fine and starts the installation on the watch. The only problem is that I cannot deselect it and install only the watchface.

I understand better now. It has to be something you are setting in the Play Console but I don’t know what it is. No one else is reporting this and I have tested this with other watch face sellers and it isn’t required.

Samsung Developer Relations

Understand. One in a million. Just my luck. I’ll keep digging.

@IndyNS – did you manage to find a solution for this? I am having the same problem (I am quite sure that “” is properly set to “true”), however the problem persists.

Hi, sorry to hear this, but I’m also relieved knowning that I’m not crazy.

No, I haven’t managed to find a solution. I’ve tried everything, even uploading a simple example from WFS and a completely empty compapp, but to no avail.

Google email support is useless as I have received 10+ emails with generic, probably AI-generated responses. Now I’m still in chat with a couple of guys asking over and over to send them the “screen recording of my issue”. They claim it has something to do with dependeces in the WF aab. I’ve sent them the WF manifest file and now I’m waiting for response. Will keep you up-to-date if something useful emerge.

My guess is that it has to do something with Play Console settings and the fact that I have created developer account after Nov '23.

I have also contacted the Google support. I will update you if I get any useful information or manage to solve the issue. Just for the info: my account has been created before Nov '23.

1 Like

Thanks! I’ve also noticed another problem related to this: screenshots for my WF are not shown in Play Store gallery which, I believe, should be the case, at least in the web version.

I’ve managed to fix the issue with the standalone WF. I did two things, so I am not quite sure which one of these two were the actual fix. The things that I changed were:

Then I uploaded the new version to the Play Store, cleared store’s cache on both the mobile phone and on the watch, and the wearable was properly detected as a standalone. As for the screenshots, I believe the WF ones appear once the app is published into the production.

Thanks for the update. My WF had higher version code from the beggining so this was probably not the fix. I’ve tried the Footprint Evaluator and my WF passed the test. Is it possible that error dissapeared when you reached the production phase?

I was hesitant to publish to production before getting it fixed, so in my case I was able to get it recognised as a standalone app while it was still in the internal and closed testing tracks.

Finally! Everything works fine now that my WF is published to production. Nevertheless, very strange and frustrating issue.