Watch face exceeds memory usage: let's clarify

Hi, never tought that 10mb need to include store photos aswell

Day 3 of resubmitting my watchface with less resources. Still it gets rejected. I also removed every touch action. I just need a clear explanation of how this freaking memory budget works.

Also, i tried multiple times to contact Google support, but I can’t get any useful answer. @r.liechty_SDR you’re probably the only person who can help us figure this out, I’m out of ideas.

1 Like

Yesterday I changed my SG-128 with WFS 1.4.20 and submitted for review. It was released without any problems. I changed the type of HR measurement and changed all complications. The size of the AAB is 5.3MB.
The only problem is that no device selection is displayed in the Playstore app since the first release on June 15th.

I have no HR measurement, and just one circular complication. This makes no sense :worried:

I have HR measurement, steps, distance, 2 complication slots and three app shortcuts.

I tried resubmitting the watchface for the 5th time. Let’s see, maybe they fixed this check today. I’m quite sure they didn’t, but i got nothing to loose.

Edit: rejected again. I’m speechless

What reason did they give was it special?

Samsung Developer Relations

“Exceeds memory budget”. Again and again. The aab size is 4.2Mb now. A single complication, no tap actions or app launchers.

Did you see what @bobota said about maybe it includes the images for the store? Check those images, I don’t think it does but hey it is worth trying.

Samsung Developer Relations

Dear All, due to memory issue, i got first rejection. Later i have submitted three more watch faces, which is OK and live now. As Ron said on earlier message “The Split Bundle error is not the memory issue it is a Play Store screw up as far as I’m concerned.”
Also note i am using software version 1.4.20. and the .aab files size all are less then 5MB.

Does this mean that the rejection is random? I’ll try another strategy: I’ll remove almost any customization option from the watchface, and if it gets published, I’ll try to update it later. Nevertheless, this makes no sense.

Hi everybody, just been looking through Google play store and find some strange file of 5.14mb which I never uploaded there. So from main Google play console go to all apps click on app which was rejected, on left side menu go to Reach and devices sub menu click App bundle explorer, click blue arrow on the right then downloads and there is file called ReTrace mapping file can be deleted, not sure for what it is, will risk and delete and send for review, will let you know outcome once Google finished reviewing

BTW all my apps that passed reviews do not have that file, only rejected

I don’t have such file. And, another update: I kept resubmitting my app, and it was rejected for another reason and not for memory budget. Then i updated the description to fix this “new” issue and resubmitted. No surprise, rejected again for memory budget.

After deleting file Rejected again

1 Like

Day 4: I checked the effective memory used in the watch itself, and this memory, in my case, was slightly over the 10MB, even if the watchface installation file is only 4.5MB.

But it makes sense, maybe the memory budget regards the memory when the app is installed. I quickly submitted another aab, this time the memory on the watch, in the app details, is just 8.5MB. I was kinda sure that this was the problem, but a couple hours later, guess what? Rejected, memory usage.

As a side note, 10MB for modern smartwatches, featuring 8+ GB of memory, is a ridiculous budget, and heavily limits our creativity and possibilities. It really makes no sense…

where did you check this “effective memory used in the watch”?

I have those files on both my accepted and rejected apps…

And the size of each apps are:
Accepted one is 3.46mb and the rejected one is 3.66mb

Maybe try re-creating watch face from scratch? (new project)

It is possible that there is some leftover from older WFS version or project version and it may cause some issues. Just a thought.

Yes, that is possible. My rejected app was initially made with the older version. I’ll try that.