Wear App showing wrong texts for customization menu!

Hi, guys recently I have notice this if you put more then 10 customizations on a watch face then Wear App mess up with the customization texts it showed wrong text where within watch customization work just fine here are the images to show what I am trying to say :slight_smile:

Watch screenshot

Wear App screenshot (It supposed to show ChangeBackground text but It’s showing HideRings which is customization two step ahead)

Another developer also faces the same problem. Here is the thread.

Didn’t saw that thread tho :slight_smile: so it’s a old bug still not resolved

This issue has been reported to WFS team and they are working on it.
Whenever we get any feedback from them, we will let you know.

I know there is a version update planned but don’t have any release date or know if this issue is solved in that.

Samsung Developer Relations

1 Like

I hope they fix it in next release :slight_smile:

Also the more styles and complications you add the more time it needs to load, sometimes you need to try multiple times when pressing customize from the wear app till it successfully opens.

I have the exact same issue on few of my watchfaces which have more customizable layers avilable in customization menu when you try via weaable app.