Launch an old watch face into emulator

When I try to launch an old watch face into emulator, it seems that it cannot be done. There is no configuration for Tizen Web Application (which in my other apps, launch into emulator), only Tizen Web Simulator Application.

What shall I do?

截屏2020-03-09上午10.37.31

Please see THIS POST, if that isn’t your problem please open a support request.

Ron
Samsung Developer Program

Tried, restarted Tizen Studio, and it does not work.

Even created a new watch face based on sample (BasicWatch template), there is an error dialog and the “Run” button is disabled.

After doing this change (and nothing else), I do an upload of my watch face to the store, and get this feedback today:

signature1.xml is invalid.
DEFECT:signature1.xml’s hash values of files are broken or signature value is invalid.
The files in the Package could be counterfeited or modification.
please check your application and do re-packaging.

I have done no other changes except to my own codes that improved the UI. Any idea?

You will get that error message when your Author Certificate does not match the original Author Certificate. Did you by chance create a new Author’s certificate or use the Tizen Author’s certificate?

This may be the cause of the emulator error as well.

Ron
Samsung Developer Program

No, the only changes I have made to Tizen Studio is the Chrome setting as mentioned in this thread.

I have been making update to my apps and upload weekly past past few months without any issues.

I have another report from a Galaxy Watch Designer user that got this same error message. I have written to the Security Review team to learn more about this. I find it strange that I’ve never heard of this error in 3 years then 2 reports in the same weekend.

You can inquire about this at the seller portal 1 : 1 and If I hear more why this error message I will let you know. If you don’t get a satisfactory response from the seller portal please open a support request and ask that Ron be copied on it.

Ron Liechty
Samsung Developer Program

Hi, luckily I made a backup of the Chrome parameter before I try the new one.

After I got rejected because “signature1.xml is invalid”, I revert back, restart Tizen Studio, do another build (no change in code), resubmit, and today the watch face is approved. I waited till it is approved (or rejected) before replying to you.

So it is either the security server somehow got problem that day, or it is due to the Chrome parameter.

Hope it helps.

Thanks for the update.

I have not heard back from the security team but it looks like an error in their system. I’ll pass this on to the other user that got the same rejection on the same day as you did.

Ron
Samsung Developer Program

You are welcome. However, my initial issues of cannot debug an old watch face on emulator (and even cannot debug on a newly created watch face), remains.