WFS Doesnt Save Progress When Adding These Pngs & Force Closes

I am having a lot of trouble with the latest watchfacestudio for the last few days on Windows 10. I have uninstalled watchface studio completely, changed project workspace directory and again installed it but its not helping.

It has happened like this around 15 times since last 7 days. This is what happens.
i add some image layers. When i try to save it , mostly it saves only one time only.
It runs and builds just fine but i am unable to save project .wfs file.
When i open windows 10 file explorer and check the wfs project file directory the file does not show saved on 2nd and later attempts .

If i try saving the project with different new name as a new file the watchface studio closes and i have lost around 7 x times plus all progress made.

EDIT: I have managed to capture the bug in 1 of the project, This happens specifically whenever i add these png images attached as zip.

All progress i make after adding this image gets lost and watch face studio doesn’t save the project for me. So i tried adding each layer separately and check if saving project works. If i don’t add these images all other layers i add gets saved without problem.

This phenomena i created more than 5 x times and every time i add this icon my watchfacestudio stops saving project. I have changed directories of these icons same result.

Faulty (3.2 KB)

Any layer made after adding any of these icons , the Watch face studio refuses to save project. Now i am sure this has happened on 2 x other projects as well in past but these images was never involved in those happenings.

Can any one check what is wrong with these icons to see if its only me or the images please. All other images are adding fine and saving as well. Is there any particular png properties i should be aware that are not supported in WFS ?

I was able to build with your .png files just fine.

You will get this if your location in the Build menu is not a writable folder for example you have /build instead of \build or it is write protected.

But strangely, I had this same problem myself just yesterday. I’d go to build and it would start then just end and for no apparent reason. I finally figured out that I had a Tap Action and that was to change the image but I had renamed the image and it wasn’t finding it.

If you figure out some other issue please let us know. If you can duplicate this with a simple project can you create a support request and upload the project.



1 Like

Thanks for testing it out Ron.
I downloaded the images above ,placed them in a new folder
and again same bug. after adding the images , i use save , close project
and the image was not saved .

I made a blank new wfs and tried 3 xtimes creating a new project added the above 3 xpngs and my watch face studio force closes and the project does not get saved.
if i try just save nothing is saved

if i i try save as the watchfacestudio crashes and closes. I can share the project file for inspection but as i mentioned above . it is happening with nothing in wfs file as well and with just these 3 x icon pngs in project.There was nothing in project except the above 3 x images.

Is there somewhere in pc i can find error log, i can share that also. i have opened a support request for this and would also like to re-open request for blank label issue which still i face since last 6 x months.

I will attach in zip the wfs, the apk ,aab ,idsig files of my watchface digitalbasic1 which i updated on 5th Apr 2022 with latest watchfacestudio .

The watchface still suffers from blank label issue.

Are these in a folder in your Workspace folder. If they aren’t then they are not in a searchable folder and it is likely that WFS can’t find them.
Make sure you are actually saving the images to your personal computer and they are not just a shortcut or stored on drive image.

You can find the log in this location
Windows : C:\Users{User}\AppData\Roaming\watchfacestudio\dump\main.log
macOS : /Users/User Name/Library/Application Support/watchfacestudio/dump/main

It probably will be very long you may rename it and launch WFS over again to start a fresh log. They are pretty readable.

Samsung Developer Relations

1 Like

I encountered this issue recently. It will force close when building the watch face because bitmaps and uploaded images in the Styles are missing. What I did was I recheck all my uploaded bitmaps and add new bitmaps using the new feature Add New Bitmap Font. I also reupload all customization images in the styles. Once you get the Images file does not exist error and WFS is not forced quit, you are near fixing it. I believe this only happens to old watch faces created in older version of WFS and reopen to new version of WFS. This bug exist also in GWS.


I have the issue now too (version 1.2.6). 2 times in a very short period of time. There is no clear reason why this happens. Yesterday everything was running normally. Today out of nowhere when trying to test on the watch (Run on Device after clicking on the listed watch device), the WFS just closed. When I open the project file again, everything is messed up. Fixing the missing links manually, as Ballozi explained, is very time consuming.

Anyone with the same problem currently? Any solutions here? Or i have to clone all projects to prevent this? :confounded:

I had that issue that resulted to Image doesn’t exist and cannot build. No workaround there but to re-upload all the images for both styles and bitmaps.

Log File - Recap

Log File - Yesterday at 27th at 15:40 (Here was all fine with WFS.)

27th at 18:23 i was still able to create a build without any issues. I am not sure if i had made a direct device test here. I don’t think so.

28th 12:06 i was able to open the project. Same information on the log file (Try to delete invalid resource bla for multiple files like the day before).

at 12:49 i had tried to Run on Device. It comes up with the popup to search the device. I have searched for the specific IP. He did found it my device (Watch 4 bla). I clicked it. On my watch opens the ADB question which i had answered with OK. Until here everything was like normal …
And than WFS has closed. Here the Log File for that.

Guys, do “save” often and create a backup file to avoid nasty surprises …

Is your problem solve? If your problem still exist, could you please share your wfs file for which you are facing this problem?
you can create support request and upload the project.

The problem occurs completely randomly. After I fixed all the missing/defective image links (listed in the log file), everything works fine with the wfs file. I was not able to figure out what kind of action is the main problem. That was the reason why I had shared my log file, so that maybe someone from the development team can understand at what moment things got messed up.

Hi matze_styles4you,

This is Jakia from Samsung Developer Program team.

Could you please share a .wfs file where this issue can be reproduced? We need this file to analyze this issue.
You can also create a support ticket to Support Request.

Thank you.

when i run into this issue again, i will open a Support Request and send you the wfs file.
Or will it also help you if I send you the file I had already fixed? :thinking: