Cannot save watch file [SOLVED]

Recently updated GWD 1.8.1 to GWS 2.0.0. After designing a watch then selecting SAVE, GWS does not save. No error messages. Then quitting GWS, it asks to save watch? Click YES, but no save occurs and GWS closes.
Any recommendation to remedy problem?
Tried reboots, uninstall GWS, re-install GWS, install GWS 2.0.0 update from GWD 1.8.1, install GWS 2.0.0 from direct download, but nothing solves problem.
PC, Win 10, Java 8 latest build, all versions up to date.

Maybe you have already tried this but just in case try saving"Save as" , sometimes when you just use the 'Save" only command it saves it but in the wrong place, not in a file called “workspace”.
GWS always looks at the workspace folder by default while trying to open a file, but does not do so while using saving.

Thank you. Already tried that. Does not work.

Open another watch face and make a small change and try to save it, that way we will know
if it is that particular watch face or something else

Thank you. Also already tried that. Still does not work.
Greatly appreciate your help so far. Hopefully we can find a solution.

Hi Mo
That tells me that it cannot find the location to save the file.
Please make sure your path for the workspace looks something like this in the file explorer
If it is not then it will not save, as this set by default

Path is/has been correct. Any other thoughts?
Thank you

Hi Mo
The only other thing I can think of is your hard drive may be full

I need more details


Hi Mo
How do you know it is not saving

Have you tried opening the GWS file or have you located the file name in the workspace

Folder and noted down the time and date it saved

Cause when you normally save the file it does not give you an acknowledgement of it being saved

Try that


Hard drive definitely not full.
I know the file is not saved because

  1. the asterisk in the watch name above the watch layout display within the GWS/GWD app should disappear once the file is saved but in this case does not, and
  2. the file does not show up in the workspace file explorer path .

One other thing I noted:
After installation of GWS 2.0.0, all of the app’s files are installed in the Gear Watch Designer folder (c:\program files\gearwatchdesigner). In this same folder, all of the GWD 1.8.1 files still remain. I would have though the GWD 1.8.1 files would have been deleted once the GWS 2.0.0 files were installed.

Thank you

When you do “save as” can you take a screenshot and display the image over here, so we can have a look at what is going on

Clicking Save in this screen does nothing. In fact, GWS freezes and the only way out is to end task in Task Manager.

I think your path is wrong, why is it showing in Admin.
It should be in a user name like Mo… in drive C

Please show the screenshot of the path in GWS in File Explorer
in C drive

workspace path is correct; my user name IS “admin”.

here is the GWS path:

Also of note, when GWS 2.0.0 is uninstalled the following error occurs:

This is in spite of the fact that the file noted in the error exists in the specified path.

Is Galaxy Watch Desginer.exe there or just Galaxy Watch Studio.exe? If just GWS then that is the correct Folder.

The last time I saw where someone could not save was because they had the location set incorrectly in their preferences. So open the GWD Preferences and see what the location is for that and set it to the correct workspace if it isn’t correct.

How GWS works is it creates a hidden folder when you open a project and when you close the project it writes it that back to the .gwd file. If the hidden folder is not in the same workspace as the .gwd file it can’t write back to it.

Samsung Developer Program

I’ll have to uninstall my GWS and download and install a new copy. I’ll let you know how that goes.

Samsung Developer Program

workspace folder.pdf (22.1 KB)
Hi Mo
This is the place you need to change the location to
Press “select Location”
that should solve the problem

workspace folder.pdf (22.1 KB)

I have followed all of the above instructions, still no resolution.

Here is the correct path set in GWS:

Here is the hidden file (.24hr GS) while GWS is open:

Here is the result after choosing SAVE (which does not save, and asks to SAVE again and again when I attempt to quit GWS):

As you can see, the file (24hr GS.gwd) has not been saved, as evidenced by the modified date not updating to 5/7/2020.