Getting Samsung Distributor Certificate

I have had some good luck and some bad luck but here is where I stand on generating a new distributor.p12

I can generate the distributor.p12 but when I go to build it says password incorrect.
@jfarell had a solution how to manually sideload using the command line and an old Tizen Fit watch installer

I’ll try that next now that I have the author.p12 and distributor.p12

next message will be how to user Tizen Studio

Samsung Developer Relations

1 Like

To generate a distributor.12 and author.p12 if you don’t have one already

download the Tizen SDK (this takes a while)

Open package manager and install the Tizen 4 and 5 wearable tools
Install the Wear extensions
Install the Samsung certificate extension
Either launch Tizen Studio and from that IDE launch Certificate Manager
from the app menu launch Tizen Studio → Certificate Manager
If you are on a preinstalled version of Windows 11 the device manager is missing an old 32 bit .dll and won’t launch but you can use GWS to connect to your watch and the certificate manager will fill in the DUID
Follow these instructions making sure you use Samsung certificates not Tizen certificates

I have a couple other things to try but I need to recuperate and try another day.

Samsung Developer Relations

Thank you for the solution! Just…now that I have both of the certificates, how do I upload the distribute certificate that I already have? I’ve manage to upload the author one, but the distribute still have the blank page instead of the log-in (I’m desperately trying to install a custom watch face on my Active2)

I’ll try the Fit Tool sideload solution to see if it works for me.

I will also see if there is a way to use the SDB command line tool to sideload it

I’d suggest you try Facer Creator I believe the basic tools are free.

Watchmaker is another option but I believe you need to purchase the companion app that controls the watch face.

Samsung Developer Relations

1 Like

Thanks for testing & providing status, Ron. Plus, the link from the old discussion thread!

Looking forward to your add’l. info (including Tizen Studio, beyond the gyrations to get certificates to work again).

Take care.

for some reason facer does not work on iphone. I can not get it to sync. I also cant get it to sync over the pc applciation.

Dear. SDP
GWS is based on Eclipse, and web views are based on IE.
Please revise the java code of GWS and request Samsung development team to modify the login webpage to be printed through Chrome.

If we re downloaded IE would it work? Like in this video?


I have downlaoded Tizen on my MAC and trying to install certificate extension but its not working.

Click on the gear icon
and make sure you accept the permissions I think that is what isn’t working. But it could be your version of macOS is older and not supported. I don’t know much about Mac Users but Smart TV Designers use it a lot so it should work.

Samsung Developer Relations

Having the same issue with getting a distributor certificate.

Tried the in-app Galaxy Watch Studio certificate request method.
Page starts loading but comes up blank.

Tried the Tizen Studio method to the same results.

Still no ETA on that hotfix you mentioned the dev team might roll out after making sure it’s secure?


good news and bad news.
The fix was done
the fix only works for Tizen Studio and won’t be done for Galaxy Watch Studio

I haven’t had time to check if the command line tool works but at least one person said it did. give it a try.

Samsung Developer Relations

My bad, not entirely sure how to use or access the Tizen Web CLI to generate a certificate.

I know it should be as simple as opening up Command Line and following some instructions, but not too familiar with how to.

Mind helping me out?



Got to create an author certificate with the help of some searching.

Couldn’t find resources for creating a distributor certificate using Tizen Web CLI, only to manage existing certs.


Been making watch faces and installing them to my Gear S3 Frontier with no problem.

Thanks for all the help Ron!


Have video for this steps? I dont understand

I just generated a new Author Certificate & tried running an install to my Galaxy Active 2 watch. I used the OS 4 option (vs. OS 5 for the newer watches) with GWS 2.0.1b.

Several things happen:
1- When I step through the get a new Author Certificate steps I see a “successful” msg … but then it says to log in to my Samsung acct (which I’m already logged into & there’s no subsequent step in the flow diagram to go to):

2- When I try to do a Build (under the Project menu in GWS 2.0.1b) it keeps defaulting to OS 5 (I manually change it back to OS 4) & with the WiFi of my rebooted Active 2 watch set to on I run a scan and GWS says it doesn’t recognize my watch (even though the IP addr that’s displayed is correct for my watch).

Am I doing something wrong?

Is Galaxy Watch Studio completely unusable at this point (for everyone)?

Must I (mandatorily) change to Tizen Studio in order to get my designs onto my Active 2 watch running OS 4? If yes, does it install and work in the same way as GWS? I’m not someone who has the know how to mess with coding or CLI and other “tricky” stuff like registries, etc.

I just design watch faces in an intuitive way starting with Photoshop, then imported content from there into GWS in the past. If Tizen Studio requires coding and complexity, I’m sunk… that’s out of my skillset. That would be so disappointing & sad.



Are you on a Mac or Windows?

Do you have developer options turned on did you restart your watch and then go to about watch and turn debugging on?

Samsung Developer Relations

I’m Win 11.

Yes. I restarted the watch. And, verified the debugging and developer options were turned on as 1st steps (before and after the restart).

I turn on the Active 2 watch’s Wifi and click on the option to Build (under Project) in GWS. Then I enter my PWD. It goes through about 1/2 the motions that it did in the past. But then I still get the long page of error codes that aborts the install. Same result if I just click on the little watch icon at upper right of the GWS UI like I used to. It recognizes the watch and tries to do the build. But then gens that page full of error code.

With GWS 2.0.1 it will almost always fail on Build and Run on Device because it has a fundamental bug in it where it doesn’t save the AoD it is there but doesn’t load in the project.

Roll back to GWS 2.0.0 You can open the old project and your AoD as designed by you will be there.

See if you can now build. If it builds wonderful, if not then there is the Distributor Certificate issue.

If it builds in the
C:\Users<yourusername>\ folder is
a hidden folder .tizen and in that folder are sdbkey and rename them before running on device. This will force the RSA Encryption request
You get a -12 certificate time out if you don’t accept the encryption key

When you run on device observe your watch very carefully a request to push the RSA encryption key to your watch will pop up, select do not show again and the accept button.

It all doesn’t go well and you get the the certificate times out let me know.

Samsung Developer Relations

I just checked online. Not seeing where to download that rel. I’m taken to 2.0.1

Do you have a link?