Newbie struggling to connect GWS to Galaxy Watch

Hey everyone.

I’m sorry, I know this has been asked a few times, but the answers to be honest seem to assume a level of knowledge of development above where I currently am.

I spent few hours today creating my first, very simple, watch face. I then ran into the problem a lot of people have trying to connect to my watch to “run on device”.

Could someone break down in very simple terms for an idiot (me) what I need to do to get this watch and GWS to acknowledge they each exist? Relevant details and what I’ve tried already, with a few questions:

MacOS Mojave
Debugging is ON on the watch
Developer mode ON on the watch (how do I turn this off again by the way?)
Ethernet disabled on Mac
Mac connected to same 2.4ghz network
Never seen an authentication message on phone, or watch
Tried sdbOverBT which also didn’t work. App kept saying could not connect to BT, check pairing. Watch definitely paired to phone.

Watch is set to sync WiFi settings from the phone - does this make a difference?
Where can I find the IP address of the watch? I can’t seem to find it under Settings -> connections

Any help and simple suggestions for a simple man will be greatly appreciated.

The instructions on how to connect really do need updating since from what I’m seeing it’s nowhere near as straight forward as they make out.

A couple of edits have been struckthough. I’ve found the IP address. For some reason tapping the Network ID didn’t work yesterday, it did today. And I’ve found how to turn off Developer Mode. The rest of this post is no change though.

i have the same problem,
but when i tried the sdboverbt it actually connected to the watch but still cant find neither the phone nor the watch on GWS.

IT IS REALLY FRUSTRATING

@mez1595027740 This is driving me up the wall. I’ve spent about 4 hours now trying to get the stupid GWS to ‘see’ my watch. Even Fitbit was easier than this to make your own watchface and try it out.

I can now add the following to try and get this to work:

4: You must have acknowledged the RSA key screen on the watch (allows for data transfer between the watch and your PC). If you missed this screen or don’t remember if you acknowledged it, disable Bluetooth, restart (power off then power on) the watch, and, after the message that shows your watch has reconnected to the network disappears, wait 30 - 60 seconds, then try connecting again. Keep your watch nearby and active as the RSA key screen displays for only a few seconds. You may need to repeat these steps (increasing the wait time after Wi-Fi has connected) to get to and acknowledge the RSA key screen.

AND I have connected both the computer and watch to my phone’s hotspot and still it doesn’t work. This is ridiculous. Not once have I seen an RSA connection message anywhere.

Oh, and I even spent an hour installing Tizen Studio and even that device manager won’t see the watch on the network either.

Well, it’s working. But NOT using GWS. I had to install Galaxy Watch Studio 1.8.1 and that is working fine. There is obviously SOMETHING not right with 2.0.

I spoke too soon. It worked for 5 minutes, I got my watch face onto my device and then BOOM, connection to the watch was lost and now I’m just getting SDB quit unexpectedly every time I try to connect. This is not a good customer experience at all. Frustrating as all get out, and zero useful understandable information on the Samsung help / FAQ pages about the issues. Essentially it’s like Trillian from Hitchhiker’s - anything you still can’t deal with is therefore your own problem.

Since you got the watch face on the Watch it isn’t the RSA acceptance, phone is not relevant if you are doing it by WiFi

Did you try the forget Network and then wait a minute and reconnect.

What Router are you using, do you have AirPort hooked up in any fashion, xfinity pods or so on?
Every time I’ve gotten an SDB quit expectantly I’ve had to restart computer and watch because things are cached.

Catalina has a lot of issues with RSA key but Mojave didn’t have them that I recall and it is probably moot if you get it connected once it remembers. If you have an older router it probably is the issue.

It sounds like you’ve thought of everything and got it to work once… it should work always. Keep trying and let us know if you have any success.

There was a streaming service for Mac that conflicted with the Port GWS uses but that was years ago, are you streaming music or anything while you are trying to connect?

I’ll try to think of any other reason.

Ron
Samsung Developer Program

Hey Ron, thanks for the reply. Using 1.8.1 I DID get the RSA message which I accepted. As I say it worked for 5 minutes, just long enough to get the watch face onto the watch then it failed to the SDB quit errors which have continued despite many computer / phone / watch restarts. 2.0 never once generated the RSA acceptance message on the watch. It’s weird that uninstalling all versions of GWS / GWD and reinstalling doesn’t clear the SDB errors, even when using a trash cleaner to hunt out orphan files.

The router is a brand new TP Link AC router, all devices connected using 2.4ghz. I think our broadband system works differently here than in the states in that we MUST use the router provided by our ISP unless we put that router in modem mode and add a 3rd party router between it and the network. Which is my setup.

In the end I dug out the 10 year old MacBook Pro (that took 20 minutes just to boot) and that connects to the watch just fine, running High Sierra. So at the moment I’m creating on one computer, transferring the gwd file to the other, building and transferring from that one. Not an ideal solution at all, but working. Mostly. It still takes 4 or 5 attempts to find the watch with “scan for devices” but it does find it eventually.

Just wish I could figure out how to clear the SDB errors on the main Mac and try again from there.

Sorry this got missed earlier.

You need the Android device to be in developer mode and you need USB Debugging on. When you first connect to your computer you will also need to agree to file transfer. By default the transfer protocol is media sharing you have to connect for file sharing and also allow data transfer.

You should then see a little android icon when you attempt to run on device.

Ron
Samsung Developer Program

HI Woody,

It is probably how you have your 3rd party router set up the same thing happens with some range extenders. You may need to use SDBoverBT and I don’t have a Mac but I know that the file sharing with that is a bit different but it works.

If you dismiss the RSA acknowledgment or don’t respond in time the very first time it is seen as a attempted Hack and does not show again. your MacBook is seen as a different device and requires a new RSA Acknowledgement to connect.

Ron
Samsung Developer Program

Hello ,
I was able to connect my smart watch to the mac by downloading Tizen Studio and replacing the sdb file from tizen studio with the one from galaxy watch studio

When you have downloaded tizen studio,
1- Open finder> user> (username)> tizen-studio> tools> (you will see the sdb file of tizen studio)
2- Then open a new finder window> applications> right click on galaxy watch studio> click where it says (shows package contents)> Contents> tizen> tools> (you will see the galaxy watch studio sdb file)
3- Replace the galaxy watch studio sdb file with the tizen studio sdb file.
4- Restart the mac and try to connect the smat watch

After 2 days of frustration this trick finally did the job for me! Thanks so much, what a relief

I have struggled from time to time but feel I have found a way to get connected by following these steps. It is a pain and I’m not sure why I have to do this almost every time since version 1.71. Hopefully it can work for you.

Follow These Steps To Get Watch Connected

• Restart GWD Program
• Restart Watch
• Turn Wi-Fi On Watch On
• Check IP Address of your watch
• Turn On Debugging

Make sure watch is online with debugging and the GWD program has been restarted.

Open a windows Cmd window and type the following commands. Please check that your directory as it may be different and put in the correct path.

• Cd C:\Program Files\Galaxy Watch Designer\tizen\tools

• sdb start-server

• Sdb connect 192.168.1.31 Use your correct IP address

After you type in the last command you should see that you are connected. Then go to the GWD program and download your watch. I keep these commands in a note file and just copy and paste as needed so it becomes easier after awhile. You may have to run the commands a few times but they should work if everything is online

Good Luck. I hope it works for you.