Can't connect to watch Mac Cataline

Just got a new mac, running Catalina.
I’m unable to connect to my Gear S3 from GWD.
No problem on the old mac (El Capitan) GWD see it right away.
Any tricks or suggestion, walk-around to get it to work under Catalina?
GWD 1.8.1, got the JDK up to date, firewall approved.

They recommend a complete restart of the computer(in fact do a complete shut down of your computer)after an update, then retry to connect after connecting to the same WiFi band of the computer and the S3, very importantly look out for the RSA key it will very briefly show up on the watch, so watch for it like a hawk accept the connection and then it should work(don’t forget to put debugging on in the watch)
Hope this helps

Hi Malcolm,
shutdown/restart of mac, unplugged the LAN to be sure to be on wifi, (both on same network)
doing the “direct” connection with the IP address manually entered…
confirmed on Java JDK 1.8 (updated to latest release of 1.8.241)
still no luck getting the RSA to pop on the watch and connect.

btw, not sure if just my installation but I do not have a “preferences” sub menu for GWD… when selecting it, nothing pops…

thanks for your assistance.


Hold down the home key on your Watch until it says rebooting This will force the RSA Encryption Key Acknowledgement dialog to run the next time you connect. Wait a a minute after it says it is connected to start a connection from the Mac for some reason it takes longer than it says. Since it is a new Mac OS any previous RSA Key acceptance would not work.

The Edit - Preferences should pop up but the connection there is just for a proxy server. Be sure to enter the IP address into GWD Run on Device menu.

Samsung Developer Program

Your preferences should show

Thanks Ron and Malcolm…
it took 3 computer reboot and 5 watch reboot to finally see it on the Mac OSX Catalina computer with the direct IP address.
I was getting annoyed.

But I do (still) have a problem with the Preference menu of GWD not showing up…
(don’t really want to uninstall GWD after all the connection issues)



If you don’t need to use the OpenWeatheMap API for your design I’d wait for the next Catalina update. I believe there is a Java problem with it.
Still you may want to submit a support request so we have it on file.

Samsung Developer Program

I have the same issues, including Preferences not showing. Have checked everything mentioned, still can’t connect. I was connecting fine until a few weeks ago. There has been a Mac OS update, that is all that has changed with my system

You have to reset the RSA key after a system update. That is most likely your problem. Hold Down the home key until it says rebooting. Restart computer phone and watch. Next time you connect be sure to watch for the RSA encryption key acknowledgement.

Regarding preferences can yo try to roll back to a previous version of Java. In the meantime See the required versions of Java HERE

Hope this helps,
Samsung Developer Program

Then I resolved connection by switching off my Mac’s WiFi and connecting to the router by ethernet cable.

That tells me you have a problem on the 2.4Ghz band on your router, or some kind of interference on that band. (VOIP phone router or a microwave etc) that is what the watch uses.
As long as you are on the same network the watch should hook up.
If I was you, I would stick to the wired ethernet network, as you would have no signal interference.

I had the same issue. I had two routers at home and it seems the divices were not at the same network. I resolved it with restarting of mac and disabling one of routers. Probably best option will be go via ethernet cable.

Thank you. Maybe GWD has just become a diagnostic tool as well. Ta-Da!!

I think I’m done with trying to get my mac to talk with GWD…
still can’t get any way to get this Catalina OS to see the watch.
SDBoverBT won’t work either.
Wired, wifi, even tried to get the mac to see the watch via BT.
nothing, nada,
Did a full reinstall of GWD, (now Studio 2.0) by deleting every possible trace of it
still no luck.
I think it’s more an issue with the OS than the software… will have to try to dig out and 8 years old PC for my watchface.
the ONLY thing I can suggest in the possible troubleshooting is (was) on my old mac (elCapitan), when I was starting GWD, I was getting prompt about "Do you want GWD to perform outgoing network connection… " or something like that.
No such prompt over Catalina…
Watch is 4 years old…maybe I should think of changing it for a WearOS instead…
any last suggestion??
…oh… and still no Preferences submenu…
Got the Java 8, build 251, and the SDK 14… (missing a setting somewhere?)
before being ask… Tried Firewall ON or OFF, gave accessibility permission to GWD…
Tried Google on how to give outgoing permission on mac, but it tell you the opposite on how to BLOCK outgoing …
I’m losing the battle…

BTW… will GWS (GWD) will ever be recognized as valid trusted install in the future by the Mac OS Security?

Thanks…and sorry for the small ranting. :slight_smile:


Hi Richard
Most of us , have gone through with what you are experiencing, so…
I think your problem is the RSA encryption key asking for a network connection and confirmation.
The RSA key appears very very briefly and disappears very fast, if you do not look out for it and miss it , you are not going to connect.
So, reboot the computer and the watch with debugging on , developer mode on and this time while trying to connect look out for the RSA key very attentively, when it shows up tap and accept and your watch should show up in GWS
Good luck bro.

I don’t know how to do this on the Mac but the problem with the preferences on Windows is the scaling for HD monitors. Perhaps someone can help with that.

I think it is because the IDE is Java based that requires the trusted installer.

Check to be sure the IP address on your computer and on the Watch have the same first 3 groups of numbers the same. i.e. 169.37.0.x
Someone said that forgetting your network and restarting it will reset it to match the computer but I think you may have to assign it manually in the modem settings.

Finally there used to be a audio streaming on Macs that used the same port as GWD did and that would keep from connecting so you may need to check the port for a conflict.

Hope this helps,

Samsung Developer Program

I can confirm this. No connection is possible with MacOS Catalina.
The watch is a Galaxy Watch with Tizen

  • same 2.4 GHz WLAN
  • fixed IP addresses for clock ( and MacOS (
  • 100 times reboot (keep Homebutton pressed) the clock (switch debugging off and on) and MacOS
  • Bluetooth switched off
  • Galaxy Watch Studio
  • all Java SE/JRE/JDK 8-/14 versions for Mac (which one is the correct one?) - in the System Preferences of MacOS, version 8 update 251 (build 1.8.0_251-b08) is always displayed - the MacOS terminal says: java -version
    java version “14.0.1” 2020-04-14
    Java™ SE Runtime Environment (build 14.0.1+7)
    Java HotSpot™ 64-Bit Server VM (build 14.0.1+7, mixed mode, sharing)
  • deactivated firewall for MacOS
  • Clock and smartphone enabled in developer mode and debugging
  • SDBoverBT also unsuccessful (does it work with MacOS at all?) - Nothing appears in the connected-watch window.

I then tried to start GWS through the finder. Here I received the following log:

Error: - Busy Port?!
Error: Unable to connect sdb port?!

A reference computer with Windows 10 and Galaxy Watch Studio works perfectly.
Are there any ideas what else you could try?


GWS uses Port 26101 check to see if there is some other app that uses it. I recall a few releases ago there was a lot of problems with a streaming service that also used that port.

One of our technicians used a tool from Tizen Studio to connect to connect and after that the GWS worked. The tool sdb.exe is also included in Galaxy Watch Studio 2.0 but it didn’t work. The Tizen Studio version worked after 3 tries and the RSA encryption key popped up and no problems after that with GWS.

contact Samsung Developer Support to get the tool and instructions on how to fix it.

Samsung Developer Program

Thanks Ron for your answer.
With the Tizen Studio and Device Manager I got a connection without any problems and the RSA query on the watch came immediately. Afterwards the clock was immediately available in the GWS.
Thanks again.


Thanks Ron, Malcolm and all the others…
Maybe installing Tizen Studio should be added to the connection troubleshooting steps…
I just did it, ran the TS connection manager, it saw my GearS3…
went straight to GWS… tada…!!! it’s there and it talks to GWS…
this was the solution.
thanks again everyone.