Cant load watch face on Active 2

I am really hoping someone can help me i have Gear Watch Studio 2.0 and a Active 2 LTE witch has already had the watch face on it but i had to reset the watch now i have been tiring for days
i Connect the watch with Tizen Studio then open Gear Watch Studio and i build the watch face and try to load it i keep getting this error

existing app is not valid for this device. rebuild the apk and try again

and i am stuck don’t know what to try next Please Help !!! thanks in advance

Hi @dra1592440909,

Does it also happen for new projects or just for old projects?
You may alter the package name of your project and try again.


Thanks for the reply and yes it happens with new projects also and i have changed the package name and the build #
any other thoughts would love to get this working Thanks

You often need to generate a new Distributor Certificate for this watch after resetting the watch. I’m pretty much sure that is the error message you’d get for an invalid distributor certificate.

Samsung Developer Program

Thanks Ron
But i did a Author and Distribute certificates
its like its trying to load and it gets to about 80% then i get that error
would love to show a screen shot incase anyone else has had that error Thanks Again

Silly question but did you turn on Debug Mode it is easy to forget after resetting.

Also tap on the software version 5 times to enable developer Options (mainly opr on AOD watch face)

Did you OK the RSA encryption key after you did the reset? If not that will stop a build but generally it just doesn’t appear to connect.

Check your AOD if it is over 10% OPR reduce it, I know it says 13% but sometimes that is the problem.

Another reason is a corrupt image file or fonts. We closed the old forum but stopping at 80% was not uncommon.

I believe you did this but also check your build settings again.

Finally if you have many watch faces installed uninstall a couple and see if that makes a difference.

Samsung Developer Program

Thanks Again Ron

Debug is on
Developer on
RSA yes
the watch face dosnt have AOD
i changed the font from yikes to one in the drop down
not sure about the build settings

one other thing i tried i just tried one of the sample watch faces and didn’t change anything i got the same error ?
any thoughts Thanks !

Just a update i also one at a time removed all the icons date heart rate steps ect rebuild after each removal and still same error

Could be a firewall issue. This happens to me if I try to side load within the Samsung Network Trr SDBoverBT

Connect your phone to your computer.
Allow Data Access
On the phone make sure USB debugging is enabled in the Developer Options

From the \program files\Galaxy Watch Designer\Tizen\Tools
copy sdboverbt_160523.apk to your phone and install it.

Make sure debugging is enable for both your watch and phone

On the phone enable USB debugging in the developer Options

Launch SDBoverBT on your phone

It will ask you to select your device it will show your watch click on it and it will be connected
You may have to agree to the RSA encryption or some other permission the first time and it doesn’t show very long so be sure you have your watch handy and running when you do that. same thing for when you connect phone to computer it may ask it may not.

Once you are connected plug your phone into your computer and allow data transfer on your phone
launch GWD and from your project chose run on device
It will start the scan and then it will show the SDBoverBT icon

You may have to agree to another permission on my watch one more time.

If that works then it is either a WiFi issue or Firewall.

Samsung Developer Program