Direct Transfer to Watch Stuck

Hi, I’ve just begun working with the Watch Studio application, and I wanted to push my first watch face to my watch. I am on Windows 10 and am attempting to move my watch face to an Active 2. I’ve been through all the steps of designing my watch face and receiving the author and distributor certificates. I have turned on debugging and developer mode on the watch. I have even renamed the SDB files in the hidden .tizen folder. I can see the watch in the available devices. But once I click on my watch to push the file to the watch, I get a popup saying “tpk package for Tizen 4.0 or later device doesn’t exist, want to build it?”. I select yes, and move onto the Build Project window. From there, I don’t touch anything except for entering my password. After that, I press build and nothing happens. I press build again, and the entire application shuts down. I know that other people have experienced the same issue (like Not able to build watchface - #7 by paikkyliini215), but I’ve uninstalled JRE (16.0.1) and the Galaxy Watch Studio and reinstalled them, rebooted my watch, and confirmed that I press yes when the RSA encryption pops up on my watch. I have even tried transferring one of the default watch faces (Secret, to be exact), and even it had the same issue. I would like to know if anyone could help. If so, I would be so grateful.

1 Like

In the Build menu make a note of the location
In GWS Open Edit → Preferences ->Project - Location Make sure that is the same
Check the On Pixel Ratio for your AOD watch face and make sure that is less than 13% under 10% is better.
Check the name of your project and make sure it is a legal name.

If all those are OK create an Sample watch face and see if you can build and install it.
If you can do that then there is probably a corrupted image or font file in your project.
Go to your Workspace and make a copy of your .gwd project then rename the copy from .gwd to .zip
you can then extract it and see if there is any corrupted resources

Hope that helps if not let us know

Samsung Developer Community

Hey Ron,

Thanks for responding. The location in the Build Menu was different from the one in the Preferences, but fixing it didn’t resolve the issue. As for the AOD (I’m assuming that means Always On Display), I don’t have one for my watch face.

I then went through and used the sample watch face named “Secret,” but it didn’t work.

I’m not sure where the issue is. Any help would be appreciated. Thanks!

1 Like

Hi Sammmy,

Were you able to generate the Author and Distributor Certificate. If you can do that then it isn’t a connection issue. If this is where you are stuck at then I can work with you on connecting Computer to Watch.

Samsung Developer Relations

Hi Ron,

Yes, I have both the author.p12 and distributor.p12 files in the user/GearWatchDesigner/keystore directory. Although, when I go to open the author certificate wizard through Project>Author Certificate and select the button to use an existing author certificate, it crashes the program in a similar manner to earlier. I don’t know if that fact will be important for future steps, but I thought I’d just inform you.


I believe you have c**hecked all the steps in FAQ 23** so I think you may have too new of the Java JRE, Can you go install the last public version of Java JDK

Get the Java JDK Windows 64 bit and install it and uninstall any other version you may have. Be sure the paths and everything are set correctly.

If for some reason you do need the newer version I can show you how to use a shortcut in GWS folder to access the older version., but it is preferred to just fix all paths and such.

I’ll check back tomorrow to see if that helped. There is more that I can look at but I know GWS is only tested on the 1.8 version of Java

Samsung Developer Program

Hi Ron,

Good news, it worked! The issue was the version of Java, as you said. For anybody else struggling with the same issue, it turns out that Java 16 is incompatible with Galaxy Watch Studio (for now). Instead of uninstalling Java 16, however, I just changed my PATH so that it has the path as Java 13.

Looking forward to getting creative again! Thanks Ron!