Impossible to install my wathface

Hi everybody,
After reinstalling my pc, impossible to install my creations on my galaxy watch active I have an error message

and the same error with the examples provided with the application. Help me

Apparently your certificate is expired… If you have a copy: try to load it; if the copy is expired: try to update; if you don’t have a copy, I dont know what to do…

1 Like

I try to create another but same error and I remembered having a backup on a hdd, it works again. thanks a lot.


When you reset your PC you have to accept the RSA Encryption key again. That is what is timing out.

Easiest Solution hold down the power key until it says restarting
Restart your computer. wait a full minute
Open a factory watch face
connect and watch for the RSA pop up.

If that doesn’t work.
To Force a new RSA key acknowledgement
Close Galaxy Watch Studio

If you are on windows go to your “Users”-folder of the logged in account and search for a “.tizen”-hidden folder. There are 2 files in it called “sdbkey” and “”.
Rename those files or move them somewhere. (they will be recreated)

Important Restart your computer don’t just turn it off and back on.

Restart your watch

You can now open GWS and when you try to run on device it will force a new acknowledgement of the RSA key so be looking for it and acknowledge it.

Samsung Developer Relations