Certificate Error

Hi Ron,

Thanks for the explanations. They help! Especially to understand the implications re: certificates. I was concerned and didn’t want to mess with them. Now I’m glad I didn’t.

We’ve tried rel. 2.0.1 and 2.0.0 (& GWD) and we get the Certif Error msg in both. As I mentioned above, the errors happened spontaneously for us both (on different computers and operating with diff. certifs. and watches and phones - though the phones are both Galaxy S10+) in the past 2-3 days. The last time I was able to successfully design, build and install a new watchface I’d created was April 9, 2022. This was the 1st attempt - since then (and after 2-3 Wear updates) - that I tried to build a new watchface for the Active2 watches.

I/we haven’t run any sideloading or used whatever SDBoverBT is.

Is there a way to back up my current certificates while I’m trying to sort this stuff out? I’m not really sure where to find the info to do so.

Thx again!

Just make a copy of the Author Certificate you already have
By default they are in C:\Users\USERNAME\GearWatchDesigner\Keystore copy the entire file and store it in a safe drive and on a flash drive or backup disk.

sideloading is the technical name for Run on Device. SdboverBT is when you use your phone connection and it does not work for Active2 so no need to worry about it.

Make sure you have debugging enabled in the Settings → About Watch it will show near the very bottom when you scroll down. If it isn’t tap on the software version 5 times to enable it.

Settings → Developer Options enabled

Can you connect to the device if you can’t connect then it is something different a firewall or your computer is plugged into the ethernet instead of on a wireless connection .

If you can connect and generate a new Distributor Certificate Let me know there is a sure fix for that too.

Ron
Samsung Developer Relations

1 Like

Thx for the explanation, Ron. No we don’t sideload. I tried to use the phone when I 1st started creating watchfaces. It didn’t work for me. So I’ve always turned the WiFi on my Active2 to On (not, Auto b/c I was concerned it might drop connection) while downloading/installing watchfaces to review or use.

Yes, that was one of the 1st things I checked when the issue started. We both have debugging enabled.

Yes. We’re using our WiFi via our LAN. It is connecting. It’s just when we try to run the build/install that we’re getting the certif error msg we never got before. BTW - just so you know - we run our PC’s with Win 10. I create png content in Ps 2022 then use that content along with elements inherent to the Samsung developer software to create my watchfaces. And, to answer your question, it is rel. 2.0.0 s/w that we’re using.

I just wanted to quickly ack your reply. Then, I’ll do the backup of the Author Certif you pointed me to as a 1st next step!

I’ll try your other suggestions re: Distributor Certif. after that backup is taken care of.

This is so frustrating (making me sad…). It would be so uplifting if it would work again before this holiday weekend kicks in. I appreciate your clear explanations and help. I’m not a super techie type.

@r.liechty_SDP

I completed the steps I said I would above (after checking our firewall too - which wasn’t the issue…).

Turns out it was the Distribute Certificate that had to be re-created in the program under the Project tab. We’re at a Tizen 5.5.x.x release on our watches.

I was just able to build/install the original watchface I was working on when 1st getting the Certif Error msg. And, also could build/install the test watchface that I made to see if there was a fluke in naming or some such thing. I seem to be back in business.

Thx so much for the helpful troubleshooting & explanatory info. It was just what was needed! :clap:

Now I’m gonna get a drink! :tropical_drink:

Have a great Memorial Day!

Now I was helped by the creation again of a certificate and Distributor again ( but reserve old BEFORE). After that, the some change in the project. Build. There were no errors. All that I wrote before here above, as well as other tips - they have not helped now.

What version of Galaxy Watch Studio are you using? If you are on a PC and it is GWS 1.0.1 then you need to use GWS 1.0.0. You can download that from the same download page but click on See previous versions.
GWS 2.0.1 has an issue with AOD that can be overcame but it is a real pain.

If that isn’t it can you create a new topic in this forum so I can be sure I have the correct information.

Ron
Samsung Developer Relations

I use Galaxy Studio Watch 2.0.0.
I had sdb error that described in this top on GWD. My own advice and the instructions that are described above did not help now. I installed GSW2.0.0. The error was preserved . Only the advice ( here, above) for changing the Distribute Certificate file and adding something or changing something after to the project - is helped.

Hi shu,

Did you delete the distributor.p12 before generating a new one? When you generate a new distributor certificate it just adds the watch ID to the file and if that file was corrupted it stays corrupted.

The -12 error is not about an expired certificate it is that the certificate can not be opened in a certain time and timed out trying.

So corrupt certificate, a certificate for an older version of Windows or Watch software will give that error. And at least one person seems to have an older version of Windows 10 that just won’t work. But everything worked fine on a different computer.

I’ve had a Windows 10 update and Watch software updates that caused me to generate new Distributor Certificates. Turning Debgging on but not turning Developer Options on will give you the certificate expired error. But usually you get that error when the RSA Encryption Key is not accepted earlier.

Ron

Did you delete the distributor.p12 before generating a new one?


No, I didn't. Didn't delete distributor.p12 before generating a new one

After all attemps and following my own instructions, I followed the advice from this topic: 1. New certificate - did not help - the error was the same (added changes in the project). 2. New distribution file - helped - after changes were added to the project.
Thank you, Ron