Distributor certificate will not create

Hi, I know there are other topics on this, but my problem is a bit special ( at the time of creating this post did not know others have the same issue) and did not find solution to it.
I made new design and wanted to send it to my watch, but i got this:


It sais that my certificate expired. So I tried to creat a new one. I put in my email address and password and clicked on create but nothing happend. I looked into the keystore file and I had this there:

Can please any of you tell me what is wrong?
I have GWD (older version) on another PC and tried it there, but the result was the same.

While it says expired but that isn’t the correct error it is timing out trying to install the watch.
You need to accept the RSA encryption key and that is most likely what is timing out. Once you disregard it you have to do things to make it show again.

If your watch updated for example Active2 updated to Tizen 5.5 then you need to create a new distributor certificate as well as accept the encryption key.

See the FAQs 21,22 and 23 on these issues and if they don’t help let me know. this is very common and has many solutions.

Ron
Samsung Developer Program

Well, I did get RSA encryption key and i accepted it. So that is not an issue. I made sure my watch is active, so the second it showd on my watch I accepted it. Then I wanted to creat the new distribution certificat and had the same issue as the other dude you responded to. I have window 10. Last update on my Active 2 was in November. So that will not be an issue as well. I really dont know what else to do. Oh, and the time on my pc and my watch is the same…

And I have Microsoft Edge and Windows updated on 15.01.2021, Defender updates every day…
I sucsesfully loaded my last watch face on 08.01.2021

Thanks Lucy,

I’ll open an issue with the Seller Portal. There are way to many people reporting this now.

Ron
Samsung Developer Program

Ok, hank you. I hope it will be resolved soon. :slight_smile:

I have the same problem. Tried on Windows 10 x64, Windows 7 x64. A distributor certificate is not generated.

We have determined this is a critical error and it is being given high attention.

Ron
Samsung Developer Program

Hi Ron,

thaks for the update. This issue affects only distribusion to my own watch, right? I am still able to upload my wark to seller portal, right? This means I will upload it without testing, but if there is a problem the team at Samsung will let me know anyway :smiley:

Hi Lucy,

I just tested it and it is working now.

I don’t think you can do a build without both Author and Developer Certificates but you don’t need to connect to the watch to create a developer certificate. You can make up a number.

Ron
Samsung Developer Program

I didn’t get it. Is there an update with a fix? :thinking:

It worked for me at 11:20 EST, when did you try it?

Ron
Samsung Developer Program

I just tried it. Does not work.

It may be a cached problem or it may be the URL hasn’t propagated fully. Restart your computer reconnect and they try again. Let me know your results. I’ll try on a second computer too.

Ron

Did not work for me, too.

I did restart and also moved old Dist cert to another folder, also removed sdbkey.pud ,too, but the result is the same

here is korea, it’s still does not working…
image

1 Like

I rebooted my PC, it didn’t solve the problem

It is a 404 error, the problem on the server side is certain, and when requesting a certificate issuance, it tries to connect to the 112.106.187.16 IP, which is the Korean IP.
It’s 2am in Korean time, so I don’t think it will be solved quickly.

I’ve tried it with 4 watches on 2 computers with 2 different user accounts on both Tizen Studio and GWS and was successful in the USA.

Ron
Samsung Developer Program

And did you create new distribution certificate? Or should the old one be valid?