Getting Samsung Distributor Certificate

Same link just below the 2.0.1 download is
See previous versions >

Ron
Samsung Developer Relations

Hi Ron,

I re-installed GWS 2.0.0. Tried running it. Didn’t work.

We even (supposedly) then tried setting Edge to enable Internet Explorer mode in Windows (I’m not sure the person working with me on it really did it properly, to be honest… b/c Chrome is my default browser typically and it didn’t seem to change). I wondered if that approach would work based on your mention of systems being affected by I.E. being EoL’d by Msft.

Anyway, next I renamed the 2 files in the .tizen folder on my C: drive.

I didn’t get any RSA request sent to my watch when I attempted another build. I was watching it like a hawk. After waiting 1-2 mins., I tried again. I did see a mention of RSA appear on my watch. I clicked on the check mark to accept it. It generated new files under the .tizen folder with the same names as what had been there before I renamed them. But the watch build attempt still produced the certif errors long box of error msgs.

Also, when I’ve tried to get a new Author certif., it never gets to a page in the step x step process where a login screen comes up. I just get a blank screen that says I need to log in to my acct. (but I’m already logged in…). Here’s a snip of that blank screen that consistently comes up:

No matter what I tried, the build definitely attempts but then l end up with the repetitive certif. error code box.

Two things to try. After the first time you don’t OK the RSA Encryption key it will not ask again

In the C:\Users<username>\ folder is a hidden folder .tizen
In that folder is sdbkey and sdpkey.pub
rename or delete them and that will force the RSA Encryption Key to appear.

If that doesn’t work it still has the certificate timed out… I know the issue and the solution is a real pain.

Ron

Yes, so that’s what I did last night (pls see my note above).

I renamed the 2 files under .tizen (sdbkey & sdbkey.pub). When the RSA key finally came up (for the 1st time) I clicked the check mark to accept it and it generated those 2 files you mentioned again under .tizen (so now I have a set of 2 renamed files and 2 with the sdbkey naming).

After that RSA key process I tried to run a build last nite (using GWS 2.0.0 on my Win 11 desktop PC), it still generated that full page of certif error msgs. Sigh.

Last month this would have been an easy fix just create a new Distributor Certificate but you can’t do that with Galaxy Watch Studio any longer.

Now you need to download Tizen Studio and use a command line tool to sideload onto the Watch.

See the first two threads in this topic.

Ron
Samsung Developer Relations

1 Like

Thanks Ron.

Tizen Studio sounds like it’s too complex and beyond my skills if it requires CLI and other types of programming…

That’s so disappointing. I wish they hadn’t changed things. I was an active watchface creator using the GWS system. Now I’ll be shut down.

I appreciate all your attempts to help!

Getting the certificates with Tizen Studio is pretty easy. I’ll see if I can document how to sideload using the command line tool or sdb commands.

Ron
Samsung Developer Relations

Hi Carl,

I’m still having no luck. Am hoping you can share what worked for you!

Which OS are you using (I’m Win 11)?

How did you generate Author & Distributor certificates that are usable with Galaxy Watch Studio (rel. 2.0.0) so that you can install custom watch faces to your watch again?

What steps did you follow - if not too much trouble for you to spell out here (or screen capture a vid), it would be very Much appreciated! Thx in advance. I hope you see this …

I generated the certificates successfully using Tizen Studio and tried copying the resulting certificate files to the appropriate folder (%USERPROFILE%\GearWatchDesigner\keystore) but it still wants to get a new certificate. Looking at the logs, it claims it can’t find the file, even though it does exist at that exact path.

ERROR [10/08-11:11:32,425](CSRGeneratorForTizen.java:345) - java.io.FileNotFoundException: C:\Users\USERNAME\GearWatchDesigner\keystore\distributor.p12 (The system cannot find the file specified)

How can I build the watch face now? I got the sideloading part figured out, but the building is a problem.

1 Like

Seems I can build it if I don’t connect my watch. If I do connect my watch, then it asks for a distributor cert.

1 Like

That’s where I’m getting hung up too…

I hope Carl checks back here and can mention how he was finally able to do the actual install to his watch vs just the design or initiation of the “Build”.

If I go the Project tab in GWS to get a new Distributor Certif. (which I already had a working one of - along with my Author Certif - prior to this all breaking) the system will fill in a large number in the empty box (so it’s getting a number from someplace… not just Distribute p.12). But it bypasses the “login” step and generates the same box of repetitive certif error msgs when I turn on my WiFi & try to install a design to my Active 2 watch - which seem to be related to the Distribute/Distributor certif.).

I checked out Facer & alternatives and don’t want to use them b/c - unlike GWS builds/installations - the Facer watch faces drain the watch battery much faster and must access the Web to update data such as weather, etc. vs handle it locally like GWS does.

BTW - Does anyone know if the new Google Pixel Watch will accept our Wear watch face designs (if Samsung’s won’t anymore…) or whether Google/watch has an SDK that will let us port our designs or create new designs to put on the Google Watch (I feel like Taylor Swift re-recording her albums to gain some control again!).

Galaxy Watch Studio was for the older Tizen based watches Galaxy Watch 4,5 and 6 are Wear OS based watches you use Watch Face Studio for those. Samsung Galaxy Watch 4, 5 and 6, Google Pixel and other Wear OS based watches run the same Wear OS and you can use Watch Face Studio to build for all of them.

You can import much of your GWS project resources into Watch Face Studio but you do need to tweak them. It is best if you start with a few samples to see how WFS works. It will be somewhat familiar but also somewhat strange.

There is a converter tool that will convert some watch faces tpk files to aab files for Wear OS, However, it is 3 years old and I don’t know if it plays well with the newest Wear 4 One UI 5 watches it should but I don’t know.

Now that SDC23 is over I am hoping I have more time to look into this and find a working solution.

Ron
Samsung Developer Relations

1 Like

The ideal solution would be if you can figure out a way for us to get working Distributor Certifs back into GWS, Ron. So we don’t have to buy new Wear watches, learn new s/w and would have the flexibility to uninstall, re-install or install (for the 1st time) our designs for older (Tizen era) watches.

Carl - who responded above - posted that he got himself up & running again. But didn’t say what worked for him. The implication was he worked with the Tizen Studio s/w (?) and somehow generated GWS-compatible certifs. But that’s not clear… Wish there was a way to find out from him how he got his installs to work again.

Most other posters above said they tried a side-loaded Tizen approach and had no luck with that. They still got certif (distrib) error messages.

Thx.

no this was reported

In other news, I managed to manually sideload my watchfaces onto my Galaxy Watch 3 using the Fit2Installer via the command prompt on Windows. I suppose users wanted to sideload apps for the Fit 2 watch, however I can confirm that this works brilliantly with the Galaxy Watch3.

And if you aren’t connected to the device you can build the app then use the distributor.p12 and sideload it to the watch. I just haven’t had time to do this because I have to do it from my home computer the Samsung Network doesn’t allow any external connections.

Ron
Samsung Developer Relations

Hello I want to create custom watch face for Galaxy Watch Active2(CFE3) SM-R830 One UI Watch 2.0 Tizen 5.5.0.2 . I am thankful for Samsung creating tools to allow editing the watch face, and though it is disappointing to read here that these tools for Tizen-based devices are deprecated and new users are no longer granted certificates, I hope that it might become possible to create custom watch faces for Galaxy Watch Active2 again someday.

I attempted to generate certificates with both Galaxy Watch Studio 2.0.1 and Tizen Studio 5.1, because I hoped that if I could get certificates, I might be able to get GWS to build a .tpk file from my .gwd file and then use Fit2Installer to re-sign and sideload the .tpk, or if it is no longer possible for GWS to build .tpk files anymore, that I could reimplement my watch face in Tizen Studio, but unfortunately nothing happens when I try to generate any certificates with either GWS or Tizen Studio. In C:\Program Files\Galaxy Watch Studio\tizen\keystore I have distributor.p12, but no author.p12. I saw that Facer Creator was recommended, but I read in many places that Facer Creator generates very inefficient unoptimized watch faces that drain the battery much faster than watch faces generated by Samsung tools, so I don’t know how to achieve the same result with that.

1 Like

Today I have managed to successfully build a watch face in Galaxy Watch Studio and install it on Galaxy Watch Active2. I hope that listing everything I did to progress can help others work around the certificate issue.

  • On Galaxy Watch Active2:
    • Enabled Debugging
    • Connected to Wi-Fi
    • Enabled Always On Wi-Fi
  • On PC, downloaded:
  • Installed Tizen Studio and Galaxy Watch Studio
    • Paired Tizen Studio to the Galaxy Watch Active2:
      • Clicked Tools->Device Manager->Remote Device Manager->Add Device
      • Typed in the IP address of the watch which is visible in its Wi-Fi settings
      • Accepted the popup on the watch
    • Attempted to generate certificates with no result, as described in my earlier post
    • Uninstalled Tizen Studio
    • changed the Windows Default Browser setting from Edge to Chrome at Start->Settings->Apps->Default Apps->Web Browser
    • Reinstalled Tizen Studio
    • Restarted the PC
  • After the above:
    • Tizen Studio began to successfully launch the Samsung Account login page!
    • I was able to generate certificates at Tools->Certificate Manager->Add New->Samsung->Mobile/Wearable:
      • Created a new certificate profile (which I named “Rita”)
      • Created a new author certificate and left the “Apply the same password” box checked
      • Clicked OK and the Samsung Login Portal appeared in Chrome alongside a window with a 5-minute timer
      • When my login was successful, the page redirected to http://localhost:4794/signin/callback which displayed “Login Successful. Please continue on the Certificate Manager UI”
      • Created a new distributor certificate
      • Selected my paired Galaxy Watch Active2’s DUID which automatically appeared in the list
  • Closed Tizen Studio, then found certificate files in C:\Users\Spurdo\SamsungCertificate\Rita.
    • Copied all the contents of C:\Users\Spurdo\SamsungCertificate\Rita to three locations, after removing any preexisting files from the other locations:
      • C:\Program Files\Galaxy Watch Studio\tizen\keystore
      • C:\Users\Spurdo\GearWatchDesigner\keystore
      • C:\Users\Spurdo\Downloads\Fit2Installer\cert
  • Opened/created my Rita.gws file in Galaxy Watch Studio
    • I had a space in a project name, and that caused an error in Fit2Installer and I was unable to refactor the space out of the .gws file despite attempting to with a hex editor. I was only successful after recreating the project from scratch in GWS with no spaces in any project name strings.
    • Clicked Project->Build
      • Yes and Generate to AOD popups
    • Clicked Project->Build again
      • Yes to save project
      • Typed the author certificate password
      • Clicked build
      • Clicked OK on “Warning signing fail keystore password was incorrect” popup (ignore)
    • Closed Galaxy Watch Studio
  • This time, Galaxy Watch Studio was able to generate C:\Users\Spurdo\Rita_TW5.tpk
    • Moved Rita_TW5.tpk to C:\Users\Spurdo\Downloads\Fit2Installer\sign_me
  • Held down Shift and while holding Shift, right-clicked in the Fit2Installer folder
    • Clicked “Open PowerShell window here”
    • Typed .\sdb.exe connect 192.168.120.64:26101 because 192.168.120.64 was my Galaxy Watch Active2’s IP address
    • Typed .\sign.bat
    • Entered the certificate password again
    • Typed .\install.bat
  • On Galaxy Watch Active2:
    • Pressed the home button and touched Settings->Apps->Permissions->Rita->Sensors toggle ON. It took me a long time to realize that apps sideloaded this way cannot access Samsung Health Service data unless you do that every time you install them.
    • Pressed the home button and touched Settings->Watch Faces->Rita
  • Finally I am able to see my watch face from Galaxy Watch Studio on the Galaxy Watch Active2 screen!
6 Likes

Thank you for taking the time to document this!

I’m dealing with a medical emergency, but will try it in a couple days b/c I’ve designed (& like to design!) watchfaces for the Active2 watch also. I’ve tried everything else noted above before your post. So, if you’ve had success, I’ve got fingers crossed I will too!

1 Like

Is there an update from GearWatchStudio in the meantime? I still don’t get the 2-way verification image to log in.
I have an older Watch Gear S3 Frontier

There are no plans to update Galaxy Watch Studio. I believe the team was disbanded 3 years ago.

The only way to create a Distributor Certificate for Tizen Devices is using Tizen Studio certificate manager tool. I think you can install using Tizen Studio or SDB command lines but I haven’t had time to check that out for proof.
You can use the Fit2Installerfor now.

@tacokoneko instructions are pretty complete but with the updated Certificate extension it asks you to launch your default browser to get the certificates.

Ron
Samsung Developer Relations

1 Like

Thank you so much for writing this out! I can verify that I was able to follow these steps today and they worked to get my Galaxy Watch Studio faces running on my Galaxy Watch 3. I was worried that they wouldn’t since my watch is neither a Fit2 nor an Active2.

1 Like