[Guide] connecting watch to wfs

Progress! I think I’m nearly there.

I have followed your tips on using adb, and have successfully connected PC to watch.
In WFS, when I click on Run on Device, the link appears in the panel, I click on it and download starts. After about 1 min it indicates launch completed.

On the watch I can now see a new face has been added to my favourites.
But it is completely blank!
I suspect this is because I’ve created the face using the “Always On” tab. When I switch to the “Normal” tab it is blank.

The WFS guide says: “Once you are happy with your always-on watch face, continue with the rest of your design by switching to normal mode”.
This suggests I ought to see what I have already designed when I shift to the Normal tab — but I don’t.

So the question now is: How do I get my Always on design into Normal mode ?

Hi Again,

Solved latest problem. I needed to click on all layers in normal mode to make them visible.
Have now downloaded to the watch, and my face design appears as it should.
Which is great, BUT:
It shows the correct date, but the wrong time!
The time is way out – approx 4 hours.
For time setting, I have switched off Automatic, and set it manually.
Other faces show the correct time.

In your project setting for the Time. Check the Timezone setting and use Sync with device You may have mistakenly set it to some other time zone.


Samsung Developer Relations