GWS and new Galaxy Watch 3: Compatibility, new features?

I am excited about the new Galaxy Watch 3 and will surely buy one soon.
As a watch face developer using GWS I of course have a lot of questions, these being only a few:
Can the new watch use the faces designed for the current Galaxy Watch?
Will there be a new version of GWS?
Will there be new complications, tags or data sources for the new watch?

Yes, Yes, I can’t announce anything yet but think you will be pleased.

Samsung Developer Team

I have the watch 3 and watch studio 2.0 beta. I have developer enabled and both PC and Watch are on the same network. When trying to connect to the watch it states no compatable devices are found and I did manually enter the IP correct. Before I drive myself crazy can anyone confirmed the watch 3 and Galaxy studio are currently compatable?

Yes they are,

Did you create a new distributor certificate? Or can’t you get that far?

Samsung Developer Team

I did create the certificate, that part went ok.
I just cant build and send the face to the watch and it does not come up as a device in the box or connect via IP.
Also thank you for the prompt reply.

EDIT: I rebooted the watch, all is well.

Hello, how exactly did u manage to fix this? I can’t seem to find the watch3 through IP… I tried rebooting the watch as you implied but it doesn’t show up?

Reboot by holding down the HOME key (bottom button) for about 15 seconds and it says rebooting. Once it reboots wait a full minute for everything to connect even if it does say connect.

Be sure WiFi Connection is always on not automatic (this one bites me a lot)

When you go to connect you will need to accept the RSA Encryption Key so watch your watch carefully when you first try connect…

Hope those help,

Samsung Developer Program

Hello, I just did again. But the watch3 isn’t popping up in the scan nor connects when I enter the IP manually. Am I missing a step? Do I have to do something before this?

What I have done is having created a Distribute CErtificate by manually entering the Watch name (Galaxy Watch3 (XXXX). ) and then created the certificate.

Please verify that you have debugging on and developer options enabled (tap on the software version 5 times to enable developer options).

Verify that your watch and computer are on the same network. Modern modems have 2.4 ghz and 5 ghz networks and they are not always the same even if they appear to be the same.

You can manually create a distributor certificate using but it won’t install on the watch it has to be the Device ID of the watch to install.

Finally are you using Mac or Windows… for Mac there is more to it.

Samsung Developer Team

Thank you very much Ron.
I had forgotten about the Debug.

Many thanks for your help and sorry if I have waisted your time.

Now Im having an issue regarding the publishing. It’s saying I don’t have the permission to upload to register an app in the Watch face category when I add the binary?

Hi Rogen,

You need to have your watch design reviewed and be approved as a watch face seller before you can upload to the store. Luckily for you the design review submission period is now open.

in October 2019 the ecosystem for watch face sellers was closed and to be able to upload you need to pass a review the first time and be approved before you can upload a watch design. You also must upload new content every 3 months or you would be removed as a Watch Face Partner. In March of 2020 all inactive sellers were removed as a partner and active partners were required to sign a new pledge or be removed.

Ron Liechty
Samsung Developer Team

Hi Ron,
got the GW3 as well. My new PC has no Wlan, so I try to connect with phone. It works on all my watches but not the GW3. What am I doing wrong?

Debugging is turned on on both devices.

When I select GW3 in sdboverbt, it says: “cannot connect BT: GW3, please check SPP connection or BT paring.”

What can I do to connect?

Hi @MalteKeller,

Did you check the developer option is also enabled on your watch? I found the issue arises when the debugging is turned on but developer option is disabled on the watch.

In fact, sometimes rebooting the watch resolves the issue as well.


Hi Azad, thank you for information.

I found it now and try it when im home.

Rebooted it now over 10 times lol :sweat_smile:

Hi Malte,

First off I assume that your GW3 is paired to your phone. if not that is the problem.

restart computer and phone
Reboot GW3 by holding down the power key until it says rebooting. not shutting off and on. Wait a full minute to be sure all connections are finished.
Keep your watch active.
Launch the sdboverbt app on your phone and select your watch.
There may be a dialog about allowing the connection or and accepting an RSA key allow them and don’t ask again.
if sdboverbt does not connect to your watch at this point let us know. Open a support request and ask for Azad and Ron to be copied

Samsung Developer Program

Tried it just like you said, but still don’t working. I will open ticket for that.

I have tried the listed steps as well and I cannot ot get the watch face to publish to my galaxy watch 3. I’ve tried it on 2 different computers just to make sure. Can you advise if the galaxy watch 3 is compatible with GWS? I’ve rebooted everything and checked IPs and even when I put in my watch IP it does not find it.

If you are on a Mac the solution below is not right. Let me know and I’ll tell you how to fix that it is a bad sdb file.

For Windows 10
Go to Settings -> Gear info -> About device.
Tap on Software version 5 times. Then a confirmation pop up displayed once the Developer options is enabled.
Make sure Debugging is on in About Watch settings
Reboot (not restart) your watch (by holding down the home key until it says rebooting)
Make sure Debugging is on after the restart
Important …Restart your Phone too
Restart your computer too.
Wait one full minute before attempting to connect.

Open Settings Connections make sure WiFi is always on. Tap on the connection and then get the IP Address and write it down

BE SURE YOUR ETHERNET CABLE IS UNPLUGGED OR THE ADAPTER IS DISABLED it isn’t enough to just be connected to the WiFi on your PC

You need to connect the Watch to the same network as the Computer WiFi Modern Modems have 2.4 and 5 Ghz bands you may need to have the PC connected to the 2.4 network.

Try to connect.

Watch your watch like a hawk and the RSA Encryption key acknowledgement should pop up.

For most people that can’t connect the problem has been allowing permissions watch for them on both the Watch and the Phone especially the RSA encryption acknowledgement when you first try to connect. (it remembers after the first time and doesn’t display again, even if you don’t accept it). It is reported that if you have your watch on a factory installed watch face and keep it active while trying to connect the RSA key acknowledgement stays on longer.

Once you’ve acknowledged the RSA encryption key create a New Distributor certificate. Distributor Certificates are specific to the device you are pushing your watch face too.

If that doesn’t work read FAQ 23

and if you are still stuck then you need to create a support request to dig deeper into this.


Hi Malte, I got another report that SDPoverBT is not working on GW3 and you have to use WiFi. Did you get this resolved?

Samsung Developer Program