GWS Not Connecting to Watch

Not used GWS for a couple of weeks until today. I’ve come to update a watchface, however, it won’t find my watch when selecting the normal ‘Run on Device’ option. No settings have changed, the only thing that has changed in the last 2 weeks was an update to my S3 watch.

Anyone had similar or know how to resolve this issue? Am connecting via wifi.


I’m experiencing the same issue on my Mac Running Mojave and trying to connect to my Gear S2. I haven’t used the GWD for a long time or the newer GWS so I can’t remember how to get a connection.

I’ve tried WiFi only and turning off Bluetooth. I’ve tried resetting my watch and still no luck.

Any thoughts?

Did get mine working this evening, doing nothing different! I did read that the S2 bluetooth needs turning off.

A system update to a watch can trigger you to approve the RSA Encryption Key.

Here are some tips
Hold down the home key until it says rebooting
Restart computer
Make sure WiFi is always on (turn blue tooth off and auto works too)
Set your watch for a preinstalled watch face
Be sure to enter the correct IP address in GWD
When you go to run on device make sure your watch is active and observe it carefully for the RSA Encryption key acknowledgement

That should do it if not there are a couple other tricks.

Samsung Developer Program

You can’t connect GWS to Gear 2 it is not supported. You’ll have to roll back to GWD 1.7.x If you did connect it wouldn’t load on the watch.

Samsung Developer Program

Ciao a tutti! Ho un problema, possiedo un galaxy watch e volevo creare una nuova watchfaces. Avevo la versione di GWD 15.4 o la 16 ( non ricordo bene) ora l’ho aggiornata alla 20 beta ma GWS non mi trova il mio smartwatch come mai? per caso la versione 20 non supporta?

Ah that’s a shame but it makes sense. I guess now I need to try and find GWD 1.7. Cheers !

I can’t find 1.6.2 or 1.7. Is there a way to get access to 1.6.2 for Mac? Cheers.

yes there is a way. maybe you would need to log in to that page before it lets you download.

Brilliant, thanks ! I didn’t see the “Previous versions” link there before. Cheers.


I am using Galaxy Watch Studio V.2.0.0_beta for Windows. Unfortunately I can’t connect to my Galaxy S3 Classic by GWS. Developer mode : on
I entered correct IP address
Restarted my watch and computer
It doesn’t work.

Could you please help me? Thank you so much for your support.

Cem Erman

Is it you can not connect or you cannot push your watch face to the device. If you can connect and generate a distributor certificate that is one thing if you can’t connect then here is what to do.

Not being able to connect has became a more common problem with the newer versions of Tizen 4. For the first time connection you have to acknowledge the RSA Key. However, it doesn’t stay very long and if you don’t allow it you will get the can’t connect error. Usually restarting your watch will force it to be displayed again but I found it took several tries and leaving it off for over a minute to force the RSA Encription acknolwedgement again.

Here is my rundown.

Go to Settings -> Gear info -> About device.
Tap on Software version 5 times. Then a confirmation pop up displayed once the Developer options is enabled.
Make sure Debugging is on in About Watch settings
Restart your watch make sure Debugging is on after the restart
Important …Restart your Phone too
If you’ve already tried to connect and failed restart your computer too.

For most people that can’t connect the problem has been allowing permissions watch for them on both the Watch and the Phone especially the RSA encryprion acknowledgement when you first try to connect. (it remembers after the first time and doesn’t display again, even if you don’t accept it)

BE SURE YOUR ETHERNET CABLE IS UNPLUGGED OR THE ADAPTOR IS DISABLED it isn’t enough to just be connected to the WiFi on your PC

You need to connect the Watch to the same network as the Computer WiFi Modern Modems have 2.4 and 5 Ghz bands you may need to have the PC connected to the 2.4 network.

I prefer to use SDBoverBT method with USB cable from your phone to the computer I like this because it eliminates firewall problems. If you need to use that let me know.

For Mac users it is reported that opening the WiFi settings on the watch and forget network and reset it allows GWD to find the watch where it previously couldn’t

Hope these help, it does work but if you don’t see the RSA acknowledgement after a few tries you probably disallowed it. more on that too.

Samsung Developer Program

Se hai uno smartwatch S2 non è supportato. Tuttavia quelli stanno diventando rari. Il solito motivo per non connettersi non è abilitare la chiave di crittografia RSA. Se cerchi “Chiave di crittografia RSA” in questo forum, dovresti trovare come farlo. In caso contrario, crea un nuovo thread e possiamo aiutarti.

If you have a S2 smart watch it isn’t supported. However those are getting rare. The usual reason for not connecting is not enabling the RSA Encryption key. If you search for “RSA Encryption Key” in this forum you should find how to do it. If not create a new thread and we can help.

Ron Liechty
Samsung Developer Program

Mi potreste spiegare come creare la chiave di crittografia RSA ( non riesco a trovare informazioni ) e come usare il SDBoverBT?

Generalmente la chiave di crittografia RSA si avvia la prima volta che si tenta di accedere all’orologio da GWS, fa parte del sistema operativo per le normative GDPR. Il problema è che se non lo fai, a volte non viene più visualizzato. Tenendo premuto il pulsante Home, in genere si ripristina il riconoscimento per essere nuovamente riconosciuto se si attende un minuto prima di riavviare.

l’app SDBoverBT viene fornita con GWS ma è necessario installarla sul telefono. Le informazioni sono QUI

Generally the RSA Encryption key will launch the first time you try to access the watch from GWS it is part of the OS for GDPR regulations. The issue is if you don’t ok it it sometimes doesn’t show again. Holding down the home button generally resets it to be acknowledged again if you wait a minute before restarting.

the SDBoverBT app comes with GWS but you need to install it on your phone. Information on it is HERE

Samsung Developer Program

Ok proverò, grazie mille Ron!