GWS Preview Capture shows white circle

Just wondering if anyone has come across this.

I’ve a fairly complex watch face in GWS and when I press the “preview capture” button in GWS to capture an image of the face, the Preview Capture just displays a plain white circle.

During development of this face I had this issue before and quitting and restarting GWS fixed the issue, but now that it’s a little more complex, that no longer succeeds.

Screenshot of the behaviour shown.



Just to add, this is GWS 2.0.0_beta, build 200403

Hi @rob1585568856,

Did you try rebooting your PC? Because usually such problems get overcome by restarting/rebooting GWS/PC.

If you get the plain white circle persistently, you may try your .gwd file to open on another PC or submit a support request.


Yeah, thanks Azad.

I’ve tried rebooting/restarting to no avail. If I close the project and load a less complex watch face into the still-running GWS the preview works. I may submit a bug if I can find out how to reproduce it.


Hi Rob
Maybe you have a RAM issue, specially as you mentioned restarting the PC did solve your problem.
Also is you have any Graphic editing software like Photoshop, GIMP etc. open at the same time it may create a memory issue.
I would try it , without any other graphic software being open.
Another thing you need to try (which I am sure you have already done is) , especially when taking screenshots is not to keep the watch face in PLAY mode.

Thanks Malcolm.

Tried these but no luck. I have 12GB of RAM in my development PC, so it’s not underspecified.

I have quite a lot of 360x360 images in the watch face, and suspect that this is the issue. GWS slows down hugely when I have lots of images.

If I have time, I’ll try and create a test case and can then raise an issue if I can reproduce it.