There is a problem…I use the Arabic language on my watch…I designed a digital clock on the WatchFaceStudio and made the numbers in English format, but the numbers appear on the watch in Arabic format…I do not want the numbers in Arabic format, I want it in English format…How can I solve the problem

set english in language settings as default.

I have already set the default English language as you explained … but when i change the language of the clock to Arabic, the clock numbers appear in Arabic format… The strange thing is that the date does not change and continues on the English format

Did you change both complications to include Arabic? Is this doing it on the watch or just in the run window in Watch Face Studio? The run Window in WFS does not do non-English Dates.

Samsung Developer Relations

My friend,I did not understand what you mean…I designed the watch face on the WatchFaceStudio and make the format for the hour and the Gregorian date in English…If the watch is in English, everything works perfectly…but when you change to the Arabic language, only the watch numbers change to Arabic numbers, and the date numbers remain in English

Deactivate all languages except English (default) for the time. Should work

If you are using a
Time Component → Digital Clock → Time
Time Component → Digital Clock → Date
they both have a separate Language setting.

The way this works if your watch is set to Sync with Mobile or you watch has a different language than English…if you select all languages and set English as Default then if your language setting is not one of the options it defaults to English otherwise it uses the Wear App Settings General → Languages.

So I would guess that you have different settings on the Date than you do on the Time. If you want to force English only then set both for English Only and that is the only setting.

If that isn’t how it is working then this is a bug please report it.

Samsung Developer Relations

hi my frinde …i use Time Component → Digital Clock → Time
Time Component → Digital Clock → Date and i set english language default only and no another language sellect. there are no options in watch to chose language only by synce via mobile.and my mobile is arabic language.when i synce to the clock the number change to arabic format but date number format Remainsin english i sure in WatchFaceStudio select english only to clock and date …in watche 3 i creat more of faces and no Problems.I have a suggestion…why don’t you try making a watch face and make your phone language Arabic and then synchronize to see the result

My apology I misunderstood I thought you wanted English on your watch no matter what your phone was.

I set English language default only and no another language selected.
You have to have Arabic selected.
In the languages setting you can search for Arabic and click Select All or select your country alone. English will remain as default.

why don’t you try making a watch face and make your phone language Arabic and then synchronize to see the result
honestly I’m afraid I won’t get it changed back :slight_smile: But if you still have this issue where Arabic is not working on the Watch please open a support request they have Arabic speaking workers.

Note the language other than US will not work on the Run emulator window at this time only on the watch

Samsung Developer Relations

Thank you my friend, and a special greeting to you for helping me…God bless you…One last question… Where can I find the support request?

Ron already share it. Here it is :blush:

Thanks Boshra,

@absentsound absentsount

After you submit the report you can also go to the same site and scroll down to see the status of that report or reply to a reply by email and ask the status.

Samsung Developer Relations

Thank you, my friend, for your interest my thread

I presented my problem on the site, but I did not receive a response now… Do you write in Arabic? Can I send my problem to your email address and I will explain it to you in detail in Arabic

I see a response was sent to you this morning. Check your spam mail. If you can respond to that and attach any images that show it.

If you can duplicate this in a very simple Date / Time only watch and upload that .wfs project that would be very helpful.

You can write in Arabic if that is more comfortable for you. I’m sure we can find a native speaker to translate it.

Samsung Developer Relations

This was indeed a bug that you found and will be fixed in an upcoming release. I don’t have a timeline for it but I hope for it early summer.

Samsung Developer Relations