I cant run on device throw WFS

Dears

i tried every thing to run on device (galaxy watch 4 classic ) with WFS 1.1.14 V but it didnt work , I saw previos topics about this issue and made every singel steps but i did’nt recive and respond from WFS , Only ( No compatbile device )

Please i need your help

Best regards

@shobakinoor
The first one sounds like your issue…

Be sure you have the latest version of WFS 1.1.14 there was a bug in 1.1.12 version where you had to restart WFS after the first time Run on Device (every time after boot up of the PC)

Select Run on Device and add your IP address one time to the search using + icon
Select Run on Device
It will show no Devices found
again click on the + and click on the IP address to the run on Device at that time your watch will ask if you want to allow debugging. click yes If you don’t OK that in a 15 or so seconds it goes away and then doesn’t ask again unless you close and restart debugging
Your watch will show in the run on devices click on it.

Here are all the solutions
Basics
Your watch and computer need to be connected to the same WiFi network. Unplug or turn off the Ethernet adaptor if you have your computer connected by Ethernet
You cannot have Firewalls or VPN enabled.

Enable developer options on your watch, and within those options, enable ADB debugging, and select debug over WiFi(it may take time to connect it took me about a minute before it shows the connection).
Allow the permissions as the watch requests them.
Go to Connections and write down the IP address your router assigns to your watch.
add that when you run on device in the + dialog.
With WFS 1.0.12 there is a bug it will connect (you know because a debugging permission is opened on the watch) but you have to close WFS and restart it because it says no devices found.
After the restart run on device should work it will spin quite a while then say launch completed.

If it doesn’t

Using File manager copy the address where you installed adb by default
C:\Users\USERNAME\AppData\Local\Programs\WatchFaceStudio\tools\window
(copy the address as text from file manger using right click on the address bar)
Open a command prompt
navigate to the folder address
cd C:\Users\USERNAME\AppData\Local\Programs\WatchFaceStudio\tools\window
Then type
adb connect 192.168.x.x:5555 (where 192.168.x.x is your watch’s IP address).
It may take a minute to connect or give a failure response
If you get a rejected error or something check your watch debugger settings.
Try in developer options to revoked permissions and force new acceptance. do the connect again.

select “run on device” within Watch Face Studio, your watch should show up.

If it connects but will not run on device create a new keystore in a new keystore folder

Ron
Samsung Developer Relations

Dear Thanks ,

In fact I followed your instraction step by step but no respond from the device , Its connected throw Cmd command but throw WFS its not , I alos turned firewall off , but no responding

thanks alot

When ADB connected did a pop up show on your watch for you to OK debugging?
If so
Did you add your IP address to the Run On Device search window?
Did Watch 4 show? did you tap on it?

Ron

Hi!

I have exactly the same problem.
Followed your instructions but no reaction from the watch.
Added IP adress. WFS keeps saying No compatible device.

Switched to my laptop and now it works…
Amazing…

//Janne

This sounds like your desktop computer was on the Ethernet and not the WiFi. Sometimes it works but rarely.

Ron
Samsung Developer Relations

You mean that it rarely works with ethernet?

Hi Jan

Correct it rarely works if you computer is hooked to the Ethernet. The instructions are to have both computer and laptop connected to the same wireless network.

I’ve had some developers say it worked but I’ve never been able to do it and always had to unplug my ethernet cable to debug or run on device with Tizen watches.

Ron
Samsung Developer Relations