Image is displayed on Preview but dissappears in my watch

So, I got this image of a map, a PNG with transparency, that is on the background of the watch. It shows without any issue on the app and the Preview screen. But on the watch, it just vanishes.

Any idea how to fix this issue?

My guess is that the glow from the digital clock is “hiding” the map.

Try lowering the opacity of the clock or using narrower numbers instead of the bold ones. See if that makes a difference. You may need to make the map brighter.

This is why you should always run on device to test your designs the preview is not a true WYSIWYG

Ron
Samsung Developer Relations

No, the glow is only on the photo. The map is not that dim to begin with. Here is a screenshot of the watch itself.

And here is the map:

I’m using this formula on the “X” field to move it based on the timezone:
((round([TMZN_OFS])*24)*-1)

And as you can see on this screenshot, the ‘preview’ (and the x field) shows the positioning working well.

And it can’t be the image being black as well. I changed the saturation on the image in the app and it still not showing.

You need to increase the brightness of your image/map a little.
The WFS working background is “neutral” or in other words, it does not exist. This editor background is not completely black.

Alternatively: Just put a very dark background (not black) behind your map/image.

I did. I increased the ‘Saturation’ of the image to maximum, still not showing.

Here, now the image is not black anymore:

And it still not showing.

Here another example, I just made the map image WHITE:
And here is the result (screenshot from watch):

Mhhh… that’s weird.
Maybe your X-Pos Tag movement on the watch is not working properly.

Are you working with masking?

No, I only got another PNG on top, with the circle crop.

X shouldn’t be a problem. Math is right. :frowning: I tested with an output text field.

Make sure you have enabled the image for both 24hr and 12hr mode in the timeline. Probably that’s not it but you never know.

I’ve tested the image on my end, and it works well without or with the tag for x field : ((round([TMZN_OFS])*24)*-1)

Screenshot_20221019_100111_sysui

You’d better to share your wfs project through the bug reporting for further anaysis.

So, I deleted the image, added again, and now it works… WTH. O.o

That’s a relief.
If you want to know more about the cause, you can contact @r.liechty_SDP to request problem analysis by sharing logs and project file.

1 Like